VR jitters.

So, here’s what I have been up to, today.
Learned a lesson, and thought It might help others.

I went about and updated to the latest BIOS today.
Lost my overclock profile. Was sure I had saved it somewhere, but couldn’t find it. I could say that I will make a mental note about it until next time I want to update the BIOS, but we all know I will forget it anyway.

All said and done I jumped into DCS to do some CAT 1 recoveries. As I put on my Rift I could see the entire view was jumping about when I was moving my noggin. Sitting perfectly still was ok. But once I looked around I got these terrible jitters.

Now since I just had updated the BIOS, and done the overclock song and dance routine, naturally I thought that had to be the culprit.

I did a repair of the Oculus software.
Didn’t help.
I reset the overclock profile.
Didn’t help.
Updated the GPU drivers.
Didn’t help.

Ok. Maybe I should google this.

The simplest solution I could find was to unplug the Rift and the sensors, and plug ’em in again.
Let’s try.

That fixed it…!

Computers… :roll_eyes:


TrackIR on? I’ve never done that.

Glad that you solved it Troll. Lately, I’ve had an issue where TIR, TARGET GUI, and A-10C UFC wouldn’t work concurrently. Solved it by moving the A-10C UFC to another USB port.

1 Like


The jitters are ba-ack…!
I started thinking. Yes, it hurts a little.
Updating the BIOS could’ve changed the USB setup somehow? I remember that allowing windows power management to turn off USB devices caused trouble for the Rift earlier. So, into the device manager I went. And lo and behold, the tickmarks were back. So, I went throught the long list of HID devices, and un-ticked the «allow the computer to turn this device off to save power».
Seems to have fixed the jitters in a quick test I did.
Let’s see if it holds…

Have you tried the oculus tray tool? It’s pretty handy for overriding changes made by drivers or Bios updates. Saves manually picking through all the devices and ticking boxes :wink:

1 Like

So OTT works again, huh? It was rendered useless by an Oculus update earlier and I never installed it on my new PC. Time for a revisit, perhaps…

1 Like

It’s hit and miss for actual ASW and PD settings, but the power management stuff seems to work fine.

1 Like

Someone else found this method useful.


1 Like

If it’s DCS it might be a DCS bug, in that sometimes ASW glitches out and the best thing to do is just restart DCS. It started happening a few open betas ago. I thought I’d throw that in there, as it might not be the Oculus driver or placement or chicken blood amount etc.

On a related note, I’ve started to turn off ASW in DCS recently, as the ‘ground buildings drag’ has started to bother me when reprojection kicks in (of which it nearly always, as DCS is not reaching 90 fps in VR for anyone).

I’ve found that setting ASW off in OTT globally and then going to the Nvidia App Control and set Virtual Reality pre-rendered frames to ‘3’ and ‘Power management mode’ to ‘Prefer max’. If you start DCS now you should avoid jitters.

Of course the ‘pre-rendered frames’ is producing latency of input, but I almost prefer that to the artifacts and/or possible jitters when ASW kicks in.

As with all these things VR fiddling, purely personal preference of what works for you, so worth a try.

1 Like

It may very well be…
VR works just fine in Oculus Home. Sometimes the jitters start in the DCS Hangar menu, or when starting the flight. The jitters remain when exiting DCS again.
My reasoning was that a sensor, or even the HMD USB was powered down by windows in the timeframe above. The jitters doesn’t look like the ASW judders.
But another strange thing happened with DCS, after the BIOS update. I turned down a DCS update early today. Didn’t want to wait, just play. Later I updated the BIOS. When I started DCS again, I was requested to log on again. That only happens after a fresh install, as I always tick the «stay logged in» box. I logged in and commanded an update.
I’m in the open beta, BTW.

Will investigate, if the problems remain, tomorrow.

Status report.
No jitters, so far, since I turned off the USB power saving. :crossed_fingers:

1 Like

I’ve ran into stuff like this before and am seriously contemplating making a personal wiki on a USB stick that I can just update with all the weird configuration stuff Ive done.

1 Like

Not related but I always turn ASW off. In X-Plane in particular the difference is so dramatic that I can’t imagine any discerning player letting it stay active. The hit on my end must be way higher than it is for others. HMD timing is perfect always with it off anyway. Totally happy.

Thanks for posting your issue/solution @Troll.

1 Like

Yeah, ASW cause too much trouble in prop aircraft to be worth it.
I have high hopes for ASW 2 :slight_smile: