Windows October Update

I am taking a one-time break from my self enforced Mudspike month off to warn my friends of what could be a big problem. Since the latest Windows update for October I have basically lost use of my PC for all but the most mundane uses such as posting warnings on nerd websites like this one. It started when I tried to download a Nvidia driver update and got a warning that the file was “incompatible with your PC”. There was no way around it. Not too worried I moved on. I later went to Oculus Home and found it in a continuous loop with a front screen stating that I had no internet connection. The 3D screen would then disintegrate, and restart–continuously. If I loaded another app such as x-plane, the rebooting Oculus Home would be super-imposed over the X-Plane VR view. If I closed Oculus, it simply wouldn’t work. Yes, it would track in the 2D screen but the HMD would be black. I then reinstalled windows but kept apps and personal settings. No Help. I then erased everything and reinstalled clean. Exact same problems. It took 5 tries to get through the “incompatible with your PC” wall before I could reinstall oculus. But even when I did, I still had and have the Home loop. The whole thing is toast at the moment. It’s not a virus. I guess it could be my router doing some strange firewall behavior but that would be new to me. And my macs have no issues whatsoever. It might be some other bad behavior on my part and Windows is completely innocent. If that’s the case I will post a mea culpa later and apologize in advance for freaking people out unnecessarily.

Oh, I also lost all my screenshots for the X-Mas thing. That plus 757/767 training starting in November basically makes further participation in the event impossible. I did make it to Norman Wells, NWT and was looking forward to finishing. I’ll post back when I get sorted.


Hmm…when did this update come out? (October obviously…). I can’t recall anything having installed on my machine in the last few days other than an NVidia driver that I elected to download and install.

I don’t even know if Windows 10 still has that whole roll back feature…if so, that’d be an option if you had it turned on, but I’m guessing you didn’t or it doesn’t work because that one is obvious.

1 Like

Also if it was 1809:

“We have paused the rollout of the Windows 10 October 2018 Update (version 1809)* for all users as we investigate isolated reports of users missing some files after updating.”

Some info on that particular problem:

1 Like

Thanks for the assist. I had windoze on autoupdate without even realizing I had opted in. That won’t happen again.

I’ve got mine sitting with an update queued. As long as I put the computer to sleep, it’s not installing the update. But it’s “Update and” shutdown or restart so It’s ready to go :confused:

I haven’t looked to see if this is the dreaded update yet, perhaps I’ll look at that tonight.

-Edit- Seems as though I’m a few versions behind, should be good.

Windows 10 lets you defer updates, but not opt out completely, as an FYI. So all windows 10 users have auto-update in some capacity.


I’ve got most functionality back. Oculus Home is still in an unusable loop. Oculus now works in apps with no degradation of performance in X-Plane (the only sim installed). I don’t know which version of Home I am looping in. Opting in or out of beta makes no difference. This very well could be an internet thing. Steam friends seems to be blocked most of the time although on occasion it will get through. Most downloads still get blocked. DCS did. But after several attempts with the installer it finally got through and started the download. Those blocks are all with Windows Defender and all Firewall settings off. As long as I have X-plane and a baseline Oculus functionality, I am good. Something is not right. But I don’t think I can blame Windows or Oculus. I’ve been doing hours of searching and nobody on the internet has issues even slightly related to mine. Router or my ISP maybe but nothing any of you need to worry about. Sorry for shouting “Fire!” in a movie theater.

You are patient ZERO…! You must be quarantined.


Maybe so. :slight_smile:

Oculus Home is working after letting it loop overnite. I just may be back in business!

Finding a lot of commonality between the 737 and 757 - or are they totally different animals (systems-wise)…?

They are fairly common. The 767-400 is quite different. I will only fly it once–for IOE. After that I will likely be too junior to ever see it again. My airline merged with another a few years ago and with that merger, we got some older PW powered 757-200s and 767-300s. Those PW 757’s lack even the basic equipment for overwater flying and are domestic only. (Why would a major airline be so cheap as to buy an ocean-crossing airplane that can’t cross an ocean?). So altogether we have:

757-200 (Rolls-Royce)
757-200 Domestic (PW)
757-300 (stretched; RR)
767-300 (PW)
767-400 (GE)

I thought our mixed 737 fleet was hard. But the “756” is a little worse I think. Still its not bad. Even if you forgot everything about the differences, you’d just need to remember to put every switch in “on” or “auto” and nothing would break :slight_smile:.

Oh, and my Oculus issues are back :frowning:


So…imagine this if you will.

Last night as the wind begins to pick up, I remember Flying PC#2 (DSC machine / Win10) is still on. I go to turn it off in case we lose power-I like nice clean shut downs. When I try to power off I find that I CANNOT do so without it auto-installing an update.

I immediately think of this thread. I say a bad word.

The wind is picking up so I go ahead and do a shutdown after update.

Twenty minutes later we lose power. It pops back on twice and then goes down for the count.

As of 1500 DST, Power is still off.

I wonder…oh I wonder, what this PC is going to look like when we finally do get power back.


Thoughts and prayers in Assembler.


Update: Power came back on and after a few screens I haven’t seen before, things seem to be working…sort of…it took DCS something like 15+ minutes to load all the way to an in the cockpit screen. I’ve updated drivers since and it seems to be faster.

That said, Oculus will not work at all…likely cause, I don’t own an Oculus system…will continue to investigate :wink:


Someone on Reddit was having some Oculus black screens and suggested cleaning off the debris of old installs. User beware…I have no idea what this thing does:

1 Like

And probably unrelated…but I did find this useful post about running a lean version of Oculus Home that gets rid of the resource heavy environment that 2.0 uses. I haven’t tried it, but I will this weekend…


And if that doesn’t work, uninstall Oculus with the Revo Uninstaller free version. Then reinstall Oculus.

1 Like

What that does is remove all remnants of video drivers from your PC. It saved me a couple of times. When you are having video driver problems, this is really nice so you actually get a clean install. The regular uninstall option often leaves things behind which could mess with your system.

However, the last time I used it, it did not work properly even though I followed all instructions. The fix is to turn off “auto-update drivers” in Windows 10 (it is ON by default) and then it did work.

So not recommended to do this with default Windows 10 settings.

1 Like