X-Plane Drift when VR enabled

Not sure if anyone can help me but I am getting something really odd when in X-Plane and I enable VR.

The situation is this: Set up a flight in a small helicopter (VSkyLabs Cambri) and enter the sim in 2d. Helicopter is configured for a cold and dark start so it is just sitting there. Hit the button I have to enable VR, then re-center the display and watch as the helicopter seems to drift right, slowly (1 cm a second?). Disable VR, and the drift stops. RE-enable VR and it starts again. Sometimes, depending on my head orientation or position, I can get it to slowly rotate. No other device does anything to move a cold/dark helicopter.

I had something similar in MSFS … ages ago with that old Bell (?) helicopter. If I was to look up and left, the helicopter would turn slowly right while in flight. Which was weird as heck and very hard to pin down to the VR view (because, looking somewhere away from the line of flight and I thought that it was an inadvertent input I was entering).

Any one else experience this?.

It only happens with the headset on my head. Which adds to the weirdness. If I put the headset on my lap. no movement. If I put my hand over the center of the lenses then the movement/rotation happens. What the heck!

Edit: HP Reverb. Only seems to affect helicopters with skids … maybe the phantom force is too low to affect the resistance of wheels?

Flight Models per Frame, maybe? It’s a bit of a stab in the dark but it would make some sense. When the headset is in use, framerates decline.

1 Like

Thanks @smokinhole. That is something that I did not consider. Also thought that maybe a plugin was affecting something … so tonight I will try reinstalling X-Plane and see what that does. And turning down the visual/details some to give more resources to the game for the flight bits.

That was it @smokinhole!. On one of the settings on the ‘General’ tab of the X-Plane Config screen sets up the number of flight-model passes per frame. Mine was on the far left (setting of 1 or 2). I bumped it a little to the right (setting of 2 or 3) and my little helicopter shuffle went away! Thanks for pointing me in the right direction! You are a rocket scientist rock star!


Far from it sir! Only a fellow traveler who’s been there. I think I have mine set at 4

© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ