DCS Landing trainer

Newbie here, i am fairly new to DCS but am able to take off and land sometimes through the training module. However it takes ages to get to the landing part, so thought I would make up a scenario where I am lined up about 10mile away and ready. But have tried everything can in mission editor and just mission to do something le this but must be missing something fairly simple I think. Any ideas where I can get a step by step instructions. Been through many many vids and RTFM but cant find zilch. Cheers

1 Like

Where do you get stuck with the mission editor?

1 Like

Well, I am probably the wrong person to answer but,

Whenever I drop a new air unit onto a map, it seems to default me to an airborne start.

The dialogue in the bottom box has options for airspeed and altitude, which I can change to something more appropriate for a final approach.

Does this not work for you?

Alternatively, if I drop an aircraft on a
runway, in that same bottom box there is also a drop down that will allow me to select something like “on runway”. That sets you up, engines running for takeoff.

Oh, the thing that got me for awhile is that, in the top box where you select aircraft type, there is another drop down where you must select “player” or “client” as the pilot.

If you don’t, that aircraft is designated as AI and you can’t fly it.

2 Likes

I wish-- Have tried all of these. What i will say is that after I have done my messing, what I get when I press fly is virtualy a video that lets the aircraft land itself, I get the outside views with the mouse etc but dosnt put me in the cockpit or any control. Dunno it may pay me to delete the saves directory, havnt found anything on YouTube. Thanks for your answers.

1 Like

@ahab This is likely what you’re missing: Skill level must be set to client or player

4 Likes

Err everywhere. I did manage to do what I was asking about but cant remember. I had to do a recovery of Win10 and lost all my saves directory.Only thing I get near to is being able to have my aircraft 10miles in sight and lined up with the runway but its a video that you cant control. I know DCS does this with a *.prk I think its called but I need the bit inbetween LOL.

1 Like

Yep done that too. tried creating new missions nothing.

1 Like

Agreed. Sounds like this will solve it.

@ahab when you select and place your aircraft on the map. In the drop down menus on the right hand side is a “skill” menu with various selections. Set the skill level to “Client” and this will give you control of the aircraft when you start the mission.

Other parameters that may help are in these menus as well.

Remember, flying the final approach and landing are only a small part of actually landing, try flying a whole circuit at a specific altitude and get used to flying slow turns and lowering flaps and gear before the final turn, this lets you get the plane “dirty” and draggy for the last part of the flight, helping you fly a stable approach.

2 Likes

yep tried that. I dont have too much trouble landing maybe 50/50 but I want to get it down on the nose with each aircraft I have, so am still on the SU25T. I usualy stop the engines as soon as I touch down. Besides the dropdowns on the right my basics are.Place the aircraft (yellow) SP then DP on the runway, aircraft turns (red). Hope might give you an insight. Cheers ( off to bed I,m in Oz ).

1 Like

Do you have the Hornet ? If so , select the “ready on the ramp” mission . Once in-cockpit , bring up the waypoint map , select waypoint “0” (which is roughly the runway threshold), and click and hold the “course” switch (below the hud controls) until you see 088 (the runway heading) . Now you have a displayed course line that you can intercept as far from the runway as you like . Note that the display will also show a continuous readout of the distance to the waypoint .

I chose the Hornet for this explanation because i’m most familiar with it , and because the inertial navigation and DDI’S make it simple to easily visualise what’s happening , but the same principle can be applied to just about any aircraft in DCS , whether radio nav with an HSI (Horizontal Situation Indicator) , or any nav system with electronic displays .

1 Like

Just ran a quick test.

Misson Editor

Coalition Screen

Basic map screen

Changed country to Russia then dropped down to find Su-25

Chose client. Interestingly, it didn’t always give “player” as an option. but “client” seemed to work.

Dropped it on map at the end of the ILS feather.

The only waypoint defaults to Turn Point which is fine. Changed the airspeed to 200kts for landing practice.

Saved as mission

Went back to main menu and chose Mission, and my saved mission. Loaded to here.

Chose my only choice, the SU-25

Dropped me right where I asked, then stalled and crashed since I don’t have any controls configured. :grin:

Does this not work for you? If not, which part specifically? We’ll get this figured out. There are some smart guys here, me notwithstanding.

5 Likes

Which aircraft do you own ? The first explanation you gave points to not owning the module you tried.

1 Like

Exactly what you have done down to the last. Saved /overwrite the mission. Fly and the aircraft is not flyable but instead end up with a video of the “mission” I want to do. One thing I have noticed with the above pics is that the character representing your aircraft is/looks like a shield wherase mine is only a small cross that is either red or yellow but changes from one to another when making the mission. As I have replied to someone else.I did ( couple of months ago ) make this mission at Batumi ( how I just cant remember ) and it worked fine. However I managed to stuff up the PC and ended up doing a WIN10 Recover where all files were lost but reinstalled WIN 10. DCS was on another SSD so didnt lose anything. I obviously lost the DIR in me Saved Games folder however. So starting the game had to go back to zero. When I attempted to make this “mission” just wont work. Would the fact that you get the Shield as your aircraft be due to an older version ( not updating) as I have seen this in other vids on Youtube ???. Cheers once again.

1 Like

Yep got the Hornet, Will try your idea ( think I already done it ) again. Shouldnt make any difference of the aircraft. Very strange why this happens. When I go into instant flight ,training everything is OK so maybe could be a “Waypoint” thing.

Obviously SU25T and P51D also F18, Harrier, FC3 with Syria and PG maps Etc. Just wondering if something stuffed up from ED after I reinstalled WIN10 and I did an update, maybe DCS could have seen me as only having trial version. Will try and check this out.

2 Likes

Or make sure your logged in to your dcs account just trying to help troubleshooting

Ok guys Well it appears to be sorted as easy as. —1/ I placed my aircraft on the runway Waypoint (1) or SP 2/ .Made a waypoint (2) out at sea 3/. made another waypoint (3) or DP further out. Then moved waypoints 1 and 3 as opposites so (1) furthest out (2) closer in (3) runway threshold. Hope this makes sense. This is all I did to make the aircraft operable. I realy dont like how this fixed the problem but at least I have a saved mission to build upon. I am going to try and replicate this problem to see if it is a bug. I will report back as I hate problems like this, ok if it was me I’ll hold my hand up, but will see.

4 Likes

Fixed — see latest reply.

Hey glad it worked! Don’t know about the whole red cross thing. That’s a mystery to me.

tried with the A10 and all good. However the plot thickens. Thought I would o a clean.exe and then repair.exe but the files are not in the Bin DIR. So then thought I’ll try Skae Zilla ( run outside of DCS Dir ) but dosnt find anything, anyhow dont want to stuff things up anymore so may leave that alone. So I go to Windows run and nothing in there either, looks like my install is in a mess. Log file saw it in F: but its in D: which would have happened when I did a Win10 recovery. No use trying dos method as the file just aint there. As I said the game is now ok but dont think I can clean or repair anymore. Dont know where the files went, will try through DCS itself. So you dont have the red/yellow airplane symbols then, thats weird. Are you in Stable Ver and updated ???.

© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ