DCS problem (offline)

#1

So quick question…it appears my internet is down due to a big storm…(on mobile now). I went to launch DCS and it says:

DCS web site not available…etc etc Offline mode requires a saved password and a successful login to operate.

Then an Authorization Failed window pops up and shows all of my modules (all of the
!) as Authorization expired. What can I do about this?

1 Like
#2

You’re required to have an internet connection to make the initial authorization. You can’t go to offline mode without doing that first. No workarounds exist that I can find.

#3

What’s weird is that I had all the modules installed and working a week ago…I can’t comprehend how offline mode isn’t available.

#4

It was an apparent change they made in 2.5.1, you have to be online before you can transition to offline mode. Once you go offline, you can remain offline indefinitely for that particular system, but you have to go back online from that same system.

Unplanned power outages, network interruptions, etc. aren’t included here, so if that applies then you’re outta luck.

#5

Haha…the power/internet is exactly the reason I need to be able to play offline.

image

#6

You kinda described 99% of DRM.

Here’s the official source of my info:

https://forums.eagle.ru/showthread.php?t=207670

#7

I’m not usually a DRM ranter…but it seems odd that there isn’t some provision for verifying that you can offline play. For instance a code you enter via a phone to the ED store that gives you a temporary authorization.

Now I’m at the mercy of Spectrum to fix our cable (probably a tree…the whole small community is out)…on a weekend.

#8

So you have to attach a log file to submit a support ticket? From a computer with no internet to my iPhone? Ugh.

#9

LOL…it accepted the support request when I attached that Will Ferrell gif… :rofl:

I think it is better than a log file… :thinking:

#10

Could you use your phone to make a hotspot, tethered wireless connect the PC to it, run the DCS authorization and pick offline? I don’t think the auth call needs much bandwidth or data to do.

2 Likes
#11

I got angry and started swearing at Spectrum’s Eliza type AI help bot…

#12

No, I don’t have a WiFi dongle, and my iPhone doesn’t hot spot…we don’t have that enabled with Sprint. Despite my anger, this is really just a case of really bad timing because I’m trying to wrap up a Mig-19 review for the magazine and I’m on a short deadline due to my own procrastination. A lightning bolt sent by the God Of Prior Planning ruined my afternoon… :upside_down_face:

1 Like
#13

Setting my system time to April 24 got me in for now… LOL for 3 days.

2 Likes
#14

I wonder if you put your PC date/time back to when DCS was last active would work? You get 3 days grace, so it would be hilarious if it worked, even if really unlikely. :slight_smile:

2 Likes
#15

Can’t you just start a hot spot with your phone and connect the PC to that ?

1 Like
#16

image

3 Likes
#17

lol can’t believe that worked. Nice!

1 Like
#18

That GIF is mesmerizing…:dizzy_face:
LOL, and having read the thread more thoroughly… I can’t believe you don’t have the hot spot function enabled! :thinking::smile:

1 Like
#19

LOL…yeah. I looked at my last set of screenshots and noted the April 23 date on them and thought maybe I could get in the 3 day grace window. That will be enough. I’m sure Spectrum will have me hooked up again by tomorrow or Mon…

1 Like
#20

Yeah. Back when I had an Android phone I used to use this program called EasyTether…which created a free hotspot. Sprint now charges $10 a month per device to enable hot spot. So I never signed up for that. I have LTE service on my phone here at the house…not sure what speed that is, but it works in a pinch at least for getting advice here…haha

1 Like