Elite Dangerous Graphics Corruption AMD R290

#1

I don’t know if anyone remembers but around Christmas time I reinstalled ED and was interested in trying the horizons pack as I bought it in the steam Christmas sale.
I had some graphics problems and tried various things to get it working. In the end after rasing a few tickets with steam and the developers and having no response whatsoever from the latter and not much help from steam I uninstalled it.

Well I tried again yesterday. Exactly the same multicolour nonsense I had before. I even tried installing on a separate ssd. Ran as administrator. Lowered the graphics to potato. Checked drivers/updates. Tried without horizons. Tried from direct directory (without steam).
I can’t think of any way to fix it. I think this might be destined for the scrap heap for me unfortunately.

I just wanted to say to all you lot out there in the elite world that if you ever hear of something similar happening or being fixed could you drop me a pm?

I’ve been through all the forums and steam forums and have never found anything that matches up to my multicoloured problem. The Only way I can describe it is like trying to run a EGA or CGA game on a SVGA system from years ago.

Thanks

1 Like

Elite Dangerous Thread
#2

What os / cpu / graphics card @Victork2? - I’ll try to take a look to see if I can help.

1 Like

#3

Win 10. I7 4590K. RADEON R290X2 16G RAM.

Got to upgrade soon but I really can’t afford it yet. But to be honest it does me fine at the moment as I’m sat so far away from a 60 inch TV that the minor improvements make little difference to me as long as the frame rate is stable

Thanks fearless really appreciate it mate

1 Like

#4

This is with Crossfire off, yes?

1 Like

#5

Have you by chance tried enabling GPU scaling in the radeon settings, display tab?? Also have you tried a older driver?

2 Likes

#6

Yep off.

That I haven’t done. It’s worth a try!

0 Likes

#7

Force the shader cache on? https://support.frontier.co.uk/kb/faq.php?id=258

Btw, Frontier Support is apparently very good - did you ticket this already, as they are fairly fast to help (unlike a lot of games)?

1 Like

#8

That’s excellent that’s 2 solid leads! Thanks guys I’ll definitely try these tonight.

I raised the ticket twice actually. Had one response asking for more information but nothing after that. (I sent them screenshots and my system specs)

0 Likes

#9

If those don’t help I would be tempted to do the following (even if a bit extreme, would at least narrow things down):

  1. Completely clean uninstall your driver with DDU, i.e. use Safe Mode - https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

  2. Set up the latest AMD driver.

  3. Set up a specific profile for ED, with Crossfire off but otherwise all defaults, and start from there. If you are running 4k then drop resolution first if it doesn’t work.

If that doesn’t work, then repeat the steps above by got back to an old driver. Maybe a year’s old or something?

1 Like

#10

That’s great advice @fearlessfrog I’ll run through the list. I’m just as we speak re installing the game as I didn’t really want it on my ssd due to limited space I’m saving for the DCS tomcat. It was only to try it.
Ill let everyone know how I get on. Thanks for taking the time to help me I really appreciate it

1 Like

#11

@fearlessfrog you really are a clever dude!

That took about 2 extra minutes to load and seems to have instantly fixed the problem.
Ill have to have a fly around but it looks perfect now. Big thanks and mudspike rescues me again!

6 Likes

#12

Now go bust some asteroids up!

3 Likes

#13

Great news @Victork2 - Elite is such a good game (go land on a planet, it’s epic!) and I’m happy you’re back in. I hope it’s ok, but I extracted this Q&A out to its own topic, as it might help others searching in the future.

For a lot of games (Elite, DCS etc) when people re-install and clean install completely, the ‘Saved Games’ directory part often gets left behind. That tends to include things like temporary shader caches (that are often game version or graphics driver version dependent) so even if you redo an install it won’t fix it. Deleting or force the cache to rebuild can sometimes help.

3 Likes

#14

Excellent news @Victork2 Glad you got it worked out! Fly safe Commander!

1 Like