End of my rope

dcs

#1

Okay I’m flying 2.5 and I’ve got a few planes… nothing special. I’ve been trying to get off the ground for a couple months. I’ve tried to go instant missions or cold and dark, or training missions. Seems like every time I go in, my control bindings are gone or different. An hour tonight in Tiger II, training cold and dark, only to run it into a Jeep across the taxiway. Rudder pedals were working fine when I started out and then somehow they wouldn’t work when I tried to use the nose steering . Need help / advice from somebody who knows what they’re doing. I can’t seem to map of profile that will stay put. seriously I’m frustrated… About to dump it all in the trash can. This coming from a guy who’s been flying sim’s off and on for 10 years or so.


#2

What’s your hardware? Thrustmaster? CH?


#3

I’m guessing it is conflicting controller assignments. It can be a hassle, but time well spent to go through the controls setup and delete all the axis assignments and go through the process of reassigning. Even something like a toe brake or something can get assigned to the stick or rudder axis and you are in for a fun ride.


#4

we can try to troubleshoot.

  1. to see your controlers setup just go to and make a prtscn pls and post it here :
    OPTIONS > CONTROLS tab > AXIS ASSIGN button

  2. for you to visualize and see your controls inputs ingame you can press RCTRL + ENTER

Both above can show if there is something mesing / mixing with your controlers.


#5

the f5 requires you hold the nose wheel steering button to turn the gear, dont know if that helps.


#6

Yes sir…last time I used it…it would only turn to the right with rudder control. Thank you for your response. Going to try to remap from a fresh slate…have done this a few times already. Some say these changes are supposed to stay in the profile…havent found that to be true


#7

Tm16000 kit, throttle and rudders


#8

Thank you for you response…I will get that up soon…


#9

I have pretty good success binding controls. What is maddening is that they won’t stay mapped. Everyday I wake up with renewed hope…that you for your help…dont give up on me.


#10

There have been a few updates that have messed with the controller assignments requiring total remapping. NOT fun.

Personally I thought they should have gone with universal mappings for many of the planes. Map the axes for “jets” and all jets are done. Map for “helos” and all helos are done. Common things like gear, flaps, trim, etc could easily be shared, and then just have the things specific to that platform broken out.

I mean, the Ka-50 and Su-25T both use Shkval and Vikhrs, why do I have to set both up individually? The MiG-29s, Su-27, 33, and J-11 all share common radar/IRST setups. Things like that.

When we had 4 planes it wasn’t a big deal. It’s getting to be a bigger and bigger deal as DCSW expands.


#11

I recommend saving each controller profile. I made a Profiles directory to hold them, and i include the plane name, device and date in the file name, with a .lua extension. You have to switch the file filter to All to see my profiles. I never did engage the .diff approach to profiles.

I do not recall losing any profile in the game. And i can send mine to others and they can load them, too. PM me if you want copies.


#12

Are you using a USB hub?

Both myself and @Dark_Star have had controller issues when using a hub, but that didn’t include the profiles disappearing. What we got was certain buttons or axis would mysteriously ignore input, then work again as if no issue. Removing the hub and all works fine.

Edit 1: I will also add that using USB extension cables have been okay. Cable length can cause signal issues when over 16ft or 9ft, depending on USB spec the device uses.

A similar issue with my brother’s new Razer Naga mouse - the side buttons 1, 4, 7 and 10 worked sporadically. Removing the hub from the mix - all was good.

Good to check the control config any time a command doesn’t register - if the profile is okay, then is somewhere down the line.

I can second the following:
-Steve’s recommendation to save profile is a good safety measure, as well as a written backup.
-DCS’s recent updates messed up some of my profiles too, which I “repaired” manually. All good since.


#13

After thinking about it some more, I wanted to add another scenario I recently found myself in, should anyone else come across this thread with their own control issues.

I had been flying one day for at least half an hour, without incident in an A10C. After being shot down, I grabbed another jet and went to takeoff, to the horror that my plane refused to pull up. I hit the fence at the end of the runway. Turns out, my joystick has disconnected. Odd, I didn’t touch the cable or move it. I feared it may be damaged/broken as when I re-connected it, it Windows made the USB connect/disconnect sounds a few times.

Turned out the USB port on the motherboard has become loose a bit after 7 years. Using another port rectified the situation. DCS seems to assign/create a “device ID” so it knew it was the same stick, and my assignments were all intact.

I have known older versions of DCS (prior to 2.5.3 when I picked it back up again) to consider a device in a new port to be different - but that was also Windows 7 (I use 10 now), so I am not sure if that was a DCS change or Windows.


#14

Thanks so much for your help…since usb ports are the likely culprit I have purchased at 3.1 usb card today…hope to get in the air soon !!!


#15

I’m hoping I’m getting everybody on this message. Kind of a newbie to these forums. Thanks for every bit of help I received on my Hardware/ controls issues. I have a USB 3.1 card on the way to me and I think it will resolve all my issues. I was on the tarmac this morning and definitely noticed the control issues with the nose steering and other controls in the cockpit. Almost had my Tiger II up in the air, but my rudders and NW steering were jammed due to data dropout. To bad, had a full load of HE.
Adios


#16

Im having the same problem right now trying to Bind a couple of MFD’s…I cant get the provile (Viggen in this case) to Save…when i try it locks up the whole program…I bound them for the F-5 with no problems. OTOH I cant get ANYTHING to safe for the F015 C…no bindings will stick


#17

I was trying to figure out this profile stuff and then I saw I was never using it to begin with. Maybe that’s why I haven’t had control issues?


#18

You probably are working with a default profile which is what every aircraft has to begin with. If you haven’t made any modifications and your flight controls section then you don’t have to shave the profile that you’re in


#19

Still having issues after removing the USB hub and replacing it with a USB card pciee. I jump into the F5 and clear all the categories for my throttle and joystick I love them all back manually and it says my nose wheel steering is mapped on the joystick but it won’t work when I start the plane up. I have tried loading profile loading F5 profiles, not using profiles and doing it manually. The interesting part is that the nose wheel steering worked once 3 weeks ago. After that nothing. I have deleted all my default luas in save games. Kind of running out of new ideas. It is somewhat demoralizing as I have only been able to start up an aircraft and takeoff once on a year. I work with this every day trying to find a solution. Yesterday I almost gave up. If you have any new ideas I’d be glad to entertain them


#20

Another problem I have is trying to get on TeamSpeak. I open up TeamSpeak try to find a server. Sometimes I can find a server sometimes not. I will type a message or perhaps send a private message to someone and nobody responds I don’t know how to get on voice so I keep tapping away at the chat messages. I was on the mudspike server one time but nobody answered and the I don’t know how to get on voice to ask somebody to respond. I’m a mess I without any way to get some help I guess I’ve got a very expensive toy that won’t get used