Help DCS Rift Performance By Disabling Automatic Oculus Home Start-Up


I finally got some time to have a closer look at 2.2 last night. With the lack of Oculus running in the back ground thanks again @fearlessfrog and the latest optimisation I can finally fly in Normandy without the terrible stutters and blurring. I have been able to increase my PD from 1.0 to 1.5 granted it seems 45 fps is about the limit with leaps to 90 with a lot of sky in veiw. The water though when I crashed an SU33 into it is a lurid green :nauseated_face:

1 Like

Could you link me on how to do that? I looked through the @fearlessfrog VR post but either didn’t see it or it was described somewhere else.

Here you go:

Thanks! That was easy and seems to have worked, I’ll test out the performance in a bit.


Glad you got the info :slight_smile:

Sorry to keep deraling the thread, hopefully this is the last question. So I went into DCS to test this out but I can’t get the Rift to display anything, the displays are black. DCS is tracking the headset movement in the menu screen though. I did a restart in case there was issue with a service but no difference. Is this method only for when using SteamVR mode? If so, I’ve read some people claim that the rift has some performance loss in steam vr.

No, this is purely just for Oculus, not SteamVR. The steps are:

  1. Reboot the PC, as in clean memory emptied out etc.
  2. Start DCS.
  3. Oculus Home doesn’t now start by default, saving some system resources.
  4. Play DCS, as it should detect the Rift.

The step (3) is usually automatic if you put the Rift to your face (it has a light detector inside the mask) or start a Rift API app then that normally brings up Oculus Home in the background. If you do want to see Oculus Home (as in you want to launch an app from there or visit their store) then just click the Oculus Home icon and accept the Admin yes/no prompt.

So your main DCS menu works in VR but your DCS mission then doesn’t work in VR? I’ve not seen that before with this. This is plain DCS, right?

DCS is starting in VR mode as I can see the desktop mirrored window but the headset displays remain powerd off or black (even when wearing it). Watching the desktop mirrored window as I move my head around I can see that it’s tracking the headset, I haven’t tried to go into a mission yet but I think it would be the same issue. I’m using the the “DCS World 2 Open Alpha” shortcut which is what I always use even though I don’t know what difference is between the other one lol.

I just tried without the tray tool running, then tried with tray tool running, then tried recycling the service in the tray tool but no joy.

Not sure, as I think we are doing the same thing but seeing different results.

You found your Oculus Home shortcut icon (as in on your desktop or start-up bar) and changed the permissions to require admin, right?


As in, that’s all you did?

I don’t have a desktop shortcut anymore so I used the start menu one, but yes, that’s all I did.
The path to that shortcut is C:\ProgramData\Microsoft\Windows\Start Menu\Oculus



Hmm, odd. Your Oculus Home ‘settings’ page shows this version and you have the same settings (just trying to narrow down what’s different):

Other than that, not sure what else to suggest. This is an Oculus Rift CV1 right? :slight_smile:

Well I have automatic app udpates unchecked but I am running, the rest is the same. If I run the Oculus app before launching DCS, VR works normally. Seems like it has to be running for me for some reason.
Edit: Rift CV1

What video card? Plus a plain HDMI connection out to the Rift or some sort of powered dongle?

Asus GTX 1070, just straight HDMI into the card

Yep, me too. Not sure why, but I guess you can’t do it.

For the Oculus Tray tool, I don’t have any settings ticked at all on the screenshot you showed, so that’s the only difference I can see so far.


Ok now I closed oculus home, and relaunched DCS and VR works. Not sure if it’s running the background still somehow but I don’t see it in the taskbar.

1 Like

Cool! It would take a reboot to get back to ‘step 1’, as really the only thing we are doing is not fragmenting a bit of spare memory with the OculusClient.exe. As Oculus Home moves to v2, that process in itself is getting big enough to claim either RAM or VRAM that an app on the edge of ASW like DCS might benefit from. For @Cib it was marginal if he could run Normandy, so not loading up OculusClient.exe before DCS helped. The driver and the normal Oculus Service are all running as normal, so it’s literally the shop/launcher part that if you launch an app yourself direct (like dcs.exe) you don’t really need.

1 Like

Now I unchecked all those tray tool checkboxes, rebooted, and launched DCS without starting the tray tool first and it worked.
So it seems like it must be one of those tray tool checkboxes, regardless of whether you have it running or not.
Thanks for the help!

1 Like

Eureka! It works for me too. Great find!

@Jeffzig, I have had your problem a couple of times when TrackIR was also running. It doesnt always cause a conflict on my rig but when it does, the Oculus stays blank. So I set TIR to not load automatically.