How to get started with a HOTAS? Q

So got my X56 HOTAS much earlier than expected, damn thing is huge takes up half my desk… anyway. got it installed and working. Understand the basics of programing things via the DCS settings but my question… how the hell do you know what and where to program stuff? What you need and where? I got the basics and can fly all my aircraft, thou not a fan of that big throttle being used as a collective for helicopters, not precise enough.

Never owned a HOTAS before, just simple flight sticks which I love, the best ever being the Microsoft FF Sidewinder stick, miss that thing. lol


I use x56 and a virpil throttle

I have a “basic set up” i use for everything. Landing gear, trim, flaps, all the basics plus clickable cockpit mode on and off and VR zoom

Then when learn a new aircraft i have all the basics in a familiar place and then i just map the aircraft specific ones.

Keep them in groups if possible (this is easy on my throttle) to make it easier


yep, same here, I try to keep generally the same bindings on the joystick for each aircraft … it helps with muscle memory.


I also try to standardize controls as much as possible just so you don’t “switch pig” yourself when you switch aircraft.

That being said, there’s a lot to be said for using the controls as they were designed for the original aircraft. Those things were put where they were for a reason generally.

Probably the best option though would be to take a look at Chuck’s guides. Chuck must put a ridiculous amount of time in each of these aircraft. I’d image he combines both point A and B above, with the allowance for flying with a keyboard and joystick setup.


Can the WAS-Up be programed to anything? I’ve tried to the keyboard, the stick hat switch and the throttle hat switch and none will take, other programs are working.

It’s impossible to see that was-up gun switch without using a TrackIR to peek to the left. I can’t believe there’s no easier way to activate that, not everyone uses a TrackIR.


(Got the HOTAS set up for startup, taxi, transition and flight finally… now to kill something. lol)

1 Like

This is what I’m doing, and that can get confusing rather quickly. The A-10, F-16, AV-8B and the F-18 all have at least one stick hat switch assigned to similar sensor management functions. However, those functions are not exactly the same, nor is their mapping.

Still, if it is for maximum authenticity we strive, @Chuck_Owl’s your uncle as every one of his guides contains a suggested control mapping.

TMS up, DMS down, don’t get them wrong or you’ll be dirt-napping!


WAS is a 4-way hat switch, you should be able to program it to any of the 4 ways on stick or throttle, your choice.


I tried none would work after programming… so I just used my TrackIR only to go to the next step of trying to program the cursor move keys to anything and same thing, nothing works.

It’s been fun, no it hasn’t, but I guess these study sims aren’t for me. Going to return this $300 hotas waste of money, go back to my simple flight stick and fly planes. lol… 3 weeks and haven’t even been able to complete the tutorials due to key assignments. :wink:

Thanks all… out.

1 Like

I think you might be possibly doing something wrong as i literally plugged my x56 in and it was plug and play

Are you using any software that might be conflicting with your binds?


NOPE… plug and play, can fly everything… tried DCS planes and IL2. Just can’t get commands via the DCS options menu to work. They register but nothing in game.

I just don’t want to waste any more time posting complaints here, will take a break. Post above was just out of frustration… it was so much easier, even flying planes with my simple flight stick and keyboard commands. I still got Longbow 2, should install and go back to that. lol.

1 Like

Its sucks when its like that mate. Feel for you.

Its weird they register in the menu but not in game. Not really sure why that would be happening other than going for the obvious things which im sure you are on top of.

The only thing i can maybe think is a conflict on the throttle side, as i only use the stick.

They should show up as 2 separate controllers on DCS, have you checked for double binds? As dcs is a complete sod for that. Especially on axis commands. Its worth a look if you havent checked already.


Are you sure you are clicking the cell in the correct column in DCS controls? Could be that you have to “scroll” the view to the right to see all your controller devices’ columns.

Could you post screenshots of what you are doing in DCS controls menu?


Don’t give up yet, we’ve all had to ask for help at some point. I’d love to help you via Discord screenshare video call.
Am based in Europe, so I can be online most days between 12:00 and 15:00 CST. Those are my evenings.
Got a busy night tonight but send me a PM if you want to try for today, I might be able to get a free 30 minutes somewhere.


Don’t give up!

It can totally be a PITA to program this stuff. But you will figure it out.

If you have the basic functionality, just play with that for bit and let the frustration subside. There are many planes I still only have basic functionality with. I just add a thing or two over time as I get stuff to work.

I don’t have this setup, but I wonder if anyone who did might be able to just email you their joystick binding file…should be like a text file at most.


Don’t forget that you guys can do screen share with the Mudspike discord.


OK… I’m sure it’s user error but I have programmed 2 hat switches on my stick. One to the was up/down/left/right and the other too the cursor to operate on my TDS, with the activation on the C button on the right side of the stick… neither work in game, forcing me to use my TrackIR to peek left and activate.

So, what am I doing wrong? Any ideas? thx

temp vid will be deleted soon - YouTube

1 Like

I’m missing one thing in the video:
when you click the cell to bind the control, click ‘ADD’ and you press the button or hat on your HOTAS, does DCS ‘fill in’ the button number?
I see there are 2 columns named “Saitek Flight …” so the one thing that might have gone wrong is binding it to the wrong device. Otherwise, I don’t know.

Any AH-64 drivers got anything to add? I don’t own the thing and it’s pretty complex so I can’t say if there’s any operator error of the helicopter. DCS controls interface looks good :+1:

@Magnum50 if this does not result in any help, you could post the vid and question to the AH-64D thread we have

1 Like

if the controls are bound, in the settings page if you press the button on the controler it should highlight what that button is biound to …


Looks like you got WAS programmed right. I use axis commands and mapped the cursor to my ministick (the X56 has one on stick and one on throttle, pick whichever), so I’m not sure how well a regular hat would work but I think it should work somewhat.

Now you say “peek and activate”, what are you using to do that? I can look around all day but the movement of my head is meaningless to anything except the mouse cursor if I use that.

One other tip–once you map a hat/button/switch, when you press it in the controller window it will snap to it. So if you map trigger to fire and then you’re at the WAS area and you click the trigger, it will scroll over to the fire setting and highlight the button there, proving that action is assigned to that category.
You could try moving that hat up/down/etc and make sure it moves to the WAS spots you assigned.


You need to open the HOTAS settings in Control Panel (Devices and Printers) Right click on the X56 icon and select Game Controller properties then Properties again when the new window opens and leave those windows open then open DCS