How to get started with a HOTAS? Q

@Ragnar what does that achieve? Genuine question as ive never had to do this nor heard of it. Having those windows open in the background wont make any difference to DCS that i can think of.
Happy to find out more though,

If those windows are not open when I load DCS several of the buttons on my X52 Pro do not register in DCS despite showing as working in the CP properties page


Thats interesting. Never come across that before.

I had an X52 standard before and that was the same deal, I found the solution in one of the DCS forums about 2 years ago so it is not specific to my rig / setup

1 Like

OK, after taking some advice here… still what am I doing wrong? WAS-UP is programmed to a hat switch (up) switch, you can see it jump to setting when I hit up, so it’s programed and working but not in game.

Quick, 40 sec to the point… been stuck on this step of the tutorials for 2 weeks, lol.

WASup Hat Switch DCS Apache - YouTube

1 Like

Quick thought… set up a hot start apache in the mission editor and see if it works … may be an issue in the tutorial


WOW… I am such an idiot. I probally shouldn’t be allowed to fly this sim.

After testing your advice temp, that wasn’t it… but then I realized what it was and now wish I could delete all this crap and go back 2 weeks in time.

I programmed all those keys to the pilot, (because it worked in the pilot seat), I haven’t programmed crap into the co-pilot seat. And that’s where you start that tutorial in.

Thanks! and OUT. lol


Glad it’s sorted and you can now blow some carp up :grin:

1 Like

OK, I’m going back to tactical shooters… my wheelhouse, lol…

So now it’s properly programmed to the CO-pilot/gunner, and now WAS-UP activates when pushing up on the hat switch and/or the keyboard… but the tutorial never goes forward. lol

Thanks, but no thanks, I’m retired… don’t need this stress. lol

1 Like

Note with those tutorials there is a timing thing. If you do things too fast/close together, it may not register.
It’s annoying, but better than the earlier days of DCS when tutorials were just in-game videos you watched, it wasn’t interactive like they are now.

So maybe try WAS right and then WAS up again?

Wrong switch @Magnum50, for the tutorial to advance you have to use the one on the TEDAC grip:

In actual gameplay, yes either WAS switch accomplished the same thing, but the tutorial keys off the TEDAC switch.

1 Like

Thanks, your right… but I got to know… how in the hell is a regular gamer, like 80% of us probably supposed to know that. lol… and even with a keyboard and HOTAS there’s no way to program all those 'required" inputs. lol

Just asking for fun, no reply needed… Packing up my $300 HOTAS and sending it back, will play FC3 with my simple flight stick. :wink: Gaming is supposed to be fun after all.

1 Like

I put them here: Required keys in the Apache AH-64D question - #12 by jenrick, there’s about 40 keyboard shortcuts total (with a lot of repeats between P and CPG) that I can run on laptop keyboard and my cobra which only has 2 hat switches, and a couple of buttons. I have yet to run into anything I can’t do in the Apache currently. Compared to the default A-10C key binds it’s a piece of cake to learn (and to setup). I get if you really just want to get back some FC simplicity, but I figured I’d leave this here in case at a later point you want to try the Apache or some else is having similar issues. :v:


Don’t forget game mode for the AH-64. I’ve not tried it, but it would at least let you fly the thing without needing to go through so much hassle.