IL-2 BOSBOMBOK Tweak & Setup Guides

I have BOSBOMBOK (so want that name to happen) running very nicely now, so as is flight sim enthusiast tradition, I’m now tweaking it until it breaks and I can complain. :slight_smile: :mudspike:

Here’s some guides and tweaks I’ve gathered, being late to this sim. Looking for more if people have any.

#Chuck’s IL-2 BoS Guide (naturellement)

The best guide to get going, from the ever reliable and high quality @Chuck_Owl

#Landscape Tweaks

Something to extend the viewing area, as handy for people with different cards/memory:

#VR Tips and Tricks

Ah, VR, the only set of enthusiasts that make a 19 year old Mormon seem laid back about spreading the word. A really nice VR config guide and discussion here:

#Sheriff’s Sim Shack Videos

A great channel for learning it all.

#Cockpit Reference Cards

An excellent reference for those looking around the cockpit (vital in VR, btw, did you hear about our savior VR, let me give you this leaflet…):

#BlackHellHound1’s Skin Museum

A beautiful collection of period skins.


OMG! Make Chuck chief of education!


I’m partial to BoSMK myself. It sounds Russian. :slight_smile:

1 Like

I’m adopting that name now. Used to call it BoS/M/K or BoX, but I see now that’s lame.

Complex engine management in BOSBOMBOK is…complex…!
Every aircraft is different. Some have auto mixture. Different combinations of oil cooler controls, water cooler control, cowl flaps, intake and outlet controls…
And then some aircraft have pitch trim and others have variable stabilizers.
Setting up the controls is a lot of work!
I love it! :wink:

BTW, @fearlessfrog, VR in BOSBOMBOK rocks! You should try it! :wink:


Actually it’s quite easy. I did it last weekend. Only took me 90 minutes of configuring, testing, configuring, testing…

Oh wait. Nevermind. Time never went by faster :wink:

1 Like

Man, this sim is really wonderful in VR. I tried flying it in 2D just to check it out old school, and the immersion factor went way down. Back in with the Rift, I began the BOM Campaign flying an F4. About a decade ago I was fortunate enough to meet Gen Gunther Rall before his passing, and asked him which of all the aircraft he had flown, which he had liked best. He replied the 109F. So, it is the F4 that I am choosing to fly this time around and it is really fantastic in VR.

If anyone knows how to get rid of the chaperone while using the Rift please let me know. Have not cracked that one yet.


Thanks @fearlessfrog. Picking up the discussion in that thread…

This is probably a good thread for it, as a tip, but I was just to lazy to copy paste :slight_smile:

I personally just use (1) of the ‘Developer’ mode, and keep the chaperone box on the floor. So here’s how mine looks:

E:\Program Files (x86)\Steam\config\steamvr.vrsettings

   "collisionBounds" : {
      "CollisionBoundsStyle" : 4

Picking up the discussion on possible ways to remove chaperone for Rift users.

My config folder does not have a steamvr.settings file. The nearest match is steamvr.vrsettings. The file looks like this:

“steamvr” : {
“mirrorViewGeometry” : “0 0 1080 600”

(sorry for the confusion I caused, so I moved the reply)

Yep, it’s steamvr.vrsettings - I’ll update that.

If you’ve never set anything in Steam VR settings (when you are in the ‘loading room’ default graphic) then it’ll be blank. You can either use the settings via the UI to change the file or just use Notepad to edit it. For reference here’s my complete file contents (i.e .chaperone dev mode on (4) and I prefer some mountains :slight_smile: ):

   "collisionBounds" : {
      "CollisionBoundsStyle" : 4
   "steamvr" : {
      "background" : "E:\\Program Files (x86)\\Steam\\steamapps\\common\\SteamVR\\\\resources\\backgrounds\\night_mountains.png",
      "mirrorViewGeometry" : "0 0 1080 600"

Good to know Sir. Will try your config. Thanks.

1 Like

Unfortunately, no joy. Still have the ring at about knee level. It’s as if SteamVR doesn’t read the file on load. BTW, edited the file in Notepad++. Thanks.

Edit: Fixed it, but not sure if it was a case of not seeing the forest for the trees. The way that I got rid of it was sitting in my chair and clicking Quick Calibrate. That put my viewpoint in SteamVR at floor level (weird), but the game runs fine and the chaperone ring is gone.

Some good VR performance tips in here:

I wouldn’t recommend copying that steamvr.vrsettings file verbatim though, as it’ll apply 1.3 supersampling to every SteamVR title. The OculusTray app is the way to go. It’s good for knowing what to change though.

Personally, I like the sharpening and the HDR on.