My TM Warthog throttle is dead! or is it?

So there has been an interesting turn of events with my Warthog throttle, and instead of cluttering up the Sim Pit thread any more I figured I’d start a separate one. So a quick recap of my issue. The other day I decided to do a deep cleaning of my computer, keyboard, hotas, etc. in which I disconnected everything from my tower for cleaning. Upon reassembly I was horrified to find that Windows wasn’t recognizing my Warthog throttle when I plugged it in! After much frantic searching of the inter webs, and trying several potential fixes I declared the throttle dead. My issue and the lack of response from the throttle while trying the fixes seemed to indicate the throttles PCB had failed.

However, tonight while I was at work my wife apparently decided to have a go at messing with it, and it lived!!! Upon returning from work I went and checked for myself and it indeed was alive. At this point I decided to smash the TM firmware update button. After a minute or so I was given an “Update Failed” message and the throttle had again gone dark! Frustrated I ask my wife what she had done, and then proceed to replicate that process with negative results. Still frustrated and growing desperate I start playing “Russian Roulette” with the Hawgs cord and my computers USB ports. After plugging into several ports and being told it wasn’t recognized, or Windows failed to install drivers, I plug into a port on the front of my tower, and it worked! However after a few minutes the throttle shut down and became unrecognized. Again I started randomly plugging into USB ports, however this time I focused on the ones directly attached to the MB. Eventually I was able to get another successful connection, and so far this one has proven to be stable.

So honestly I don’t really have a clue what’s going on at this point. It could be my computers USB ports, it could be an issue with Windows 7, or maybe the throttles PCB is on the fritz. Not a clue. Time will tell I guess, especially once I work up the nerve to reboot my computer, assuming the throttle doesn’t randomly go unrecognized again. :rofl:

PS. I want to thank everyone over in the Sim Pit thread for their support, I really appreciate it!

PPS. Sorry for the essay!

7 Likes

Your…wife…?
WIFE!?
Your wife has such skills and interests…?

Does your wife have a PC that you could test the throttle on?

3 Likes

Prep the Wife of the Year Award!

I recall having a similar issue way back. Windows 7 can deactivate a USB port if it detects power anomalies. I don’t recall if it doesn’t this based on the device (ignore device X on port Y) or blanket (ignore port Y always). There is a way to check that out, could be worth a search. A bit of static interference can trip it, I’d suppose.

I also had a finnicky time with the firmware update that involved many port swaps and attempts to “force” it. It could also be a firmware issue, there was a guide from TM on how to “force” the update if I recall correctly.

And as troll states, try another PC too.
Windows 7 is…well I am glad I don’t have it anymore. Go Windows 10!

2 Likes

There’s a proverb in German: “Den Teufel mit dem Beelzebub austreiben”, literally trading the Devil for Beelzebub. :wink:

3 Likes

Interests? No. Skills? Giver her a YouTube video or decent step by step instructions and she can get the job done. She also is her parents 24/7 tech support hot line. :rofl:

Unfortunately no other PCs in the house, and I doubt it would play nice with an Apple laptop.

@Wes The stuff my Wife was reading and the troubleshooting she was doing revolved around something along the lines of what you described, and my fiddling seems to support it. It’s just strange that I have never had any issues until now. As for Windows 10, this computer will probably never see it unless I feel the need to upgrade it after I pass it on to my Wife once my new one is built.

2 Likes

Quick little update. After getting it to connect to a USB on the MB last night I let everything sit over night with power on and the throttle stayed connected. This morning I ran my computer threw a few shut down/boot cycles while leaving the throttle plugged in and so far everything is working as advertised.

Check for cable strain damage - I have had a port on my old tower get loose with age and only devices/cables that didn’t try to induce any sag would work on it. IIRC, it was my rudder pedals at fault - they require a USB extension cable which is pretty beefy. Swapping it’s port with another device worked A-Ok.

Same can happen if the cable is taught.

Edit: Also check those internal USB headers on the motherboard. It’s possible vibration over time can loosen them. I saw similar the other day with HPN’s audio header - never been touched since built, yet it was a hair crooked.

Could also be shorts inside the warthog where some insulation has been sheared.

1 Like

Mine has been on the blink for a while now it seems- dog bumps my rig, the throttle flickers and disconnects. Now that I’ve got everything dismantled for the move, I’ll crack it open and see if anything looks amiss- I may be looking for a new PCB as well.

1 Like

I vaguely remember reading that the connections to the throttle levers have a tendency to become abraded by rubbing on the base during use. Seems unlikely that that would out the entire board including the USB interface, but who knows.

mine died last year, the PCB when disassembled had a dark solder joint on one of the Chips. tje same chip that is a hair away from rubbing the metal floor board of the throttle.

if it works on specific usb ports it sounds like you are having a power problem on the mainboard, the USB ports arent supplying enough power to properly boot the device.

1 Like

My WH throttle died a couple of years ago, after a cleanup around my PC area. Had to get a replacement PCB. Which my wife soldered in for me… as my only electronics experience is replacing batteries in the TV remote.

3 Likes

there shoulsnt be any soldering,

its drop in, connect the ZIF connectors, screw the ground screw to its station and put the base back on.

1 Like

This!

Andy, what you describe is exactly what I went through two years ago. A new PCB will be in your future. On the good side it was really easy to install, the bad it was about $55.

Symptoms intermittent connection on system start, replugging sometimes worked. I searched and found the Bricked PCB was the answer.

After repair now I only disconnect / connect with the machine off. No issues since.

Good luck with the project
Wingy

4 Likes

Correct, I’d forgotten. It was a hot glue gun that she used. Think the original PCB had glued connections.

the ZIFs had hot glue over them to keep them from working loose.

1 Like

So finally got a chance to boot my computer back up and unlike earlier in the week the throttle did not boot with the computer. Fiddled around with it a bit and currently if plugged into a standard USB port my computer wont recognize it. If plugged into a USB 3.0 it would be recognized and Windows would try to load it but would fail. After unplugging all USB devices minus my mouse and keyboard and then plugging the throttle into a USB 3.0 it booted right up. Currently I have all my other USB devices plugged back in and the throttle is working fine. After this current round of fiddling I’m leaning towards a possible voltage issue as some of you have mentioned. But weather its the throttle, my computer, or perhaps alittle of both I cant say. :man_shrugging: At this point I’m going to see about getting a new PCB from TM, and worst case it is my computer and I know have a spare PCB for when mine does finally go out. :rofl:

How does one go about doing this? Thinking I may do the same.

This ^^^ is what happened to a friends Warthog throttle. I soldered on a replacement usb cable but that did not work. So he sent the board to a guy in Canada who replaced the chip for like $55 and the shipping was like $25. But my friend did not use the guys recommended description for the package contents so Canadian customs held the package for a tariff. My friend did not pay that so got the package back and resent it with the right description.

The fixed board came back and we put it back together and all was well.

© 2019 Mudspike.com | Articles Website | Forums Rules & FAQ