Oculus "Can't reach runtime service"

She’s down! I think I jinxed myself with my comment about the constant upgrade cycle. I have tried Stopping and Starting Oculus Runtime Services. I’ve tried Uninstalling the Runtime Service. Basically I’ve tried everything on Redit short of reinstalling Windows. I’ve made no changes like software installs or driver updates since I last successfully used it. One hour it worked, the next DEAD.

Hello Xbox!

1 Like

One comment I saw had to do with how much space you have on your HD…if you are under a certain amount the update hangs. How much space do you have free?

1 Like

Thanks! 189 Gb Free.

I am reinstalling Oculus now. Fingers crossed.

Reinstalled. No joy.


And btw this a global problem with Oculus today, March 7. A certificate of some sort has expired within the Oculus software. The fix is to type “svcs” in the Start prompt and scroll to Oculus runtime services and stop the service. Now change your PC’s date and time to some past date. Click restart on the same “Services” line that was stopped a moment ago. Hopefully this will work for you…it did for me!


So was it a “phone home” type problem where the error was on the Oculus end?

Hmm. The clock issue rings a bell. Didn’t Oculus have this issue before?

Edit: solution

A bit late to this party, but my 2 cents:

Do not change your system clock.

Doing so will upset a bunch of things on your system, including most game DRM activations, some secure websites and the like. Unless you really need to use the Rift then it would be best to wait for a new installation download that has to come from Oculus.

Facebook/Oculus really dun goofed on this one, expiring certificates is a dumb mistake, especially for the updater (as it can’t now update itself).

I didn’t change the system clock (the “BIOS clock”). Just Windows date and time. Oculus will figure this out today and I’ll change it back.

That’s exactly the one I meant. It can cause all sorts of issues unfortunately. If it works for you, that’s great, but I’m just letting people know what can happen, and that it’s often not a ‘no consequences’ thing, especially for gaming DRM and connected services (Google drive, LiveDrive etc). :slight_smile:

That reminds me…I need to renew the Mudspike domain na



I wonder if they sack the software guy :stuck_out_tongue:

Maybe they’ll set a reminder to do it, but then forget?


So this is probably worse than when I set a reminder to roll the recycle bin down to the curb. And it goes off, but I put it off. Then forget. Then I have a full recycle bin to try to mash stuff down into for another two weeks.

Probably worse than that.

1 Like

As you may imagine, during lambing sitting in the house in the middle of the night between visits to the pens I game a lot. Last year I did the SH 5 campaign on hardcore realism settings in real time. Yeah I know. This year RO 2 Vietnam is my go to game along with DCS and XP 11. It has been updated and Steam is not liking the update process. It sticks right at the end going through an installation on some endless loop and i have already downloaded the 7.2 Gb twice. Grrrr I suppose I could learn Elite Dangerous in 2d :frowning:

Damn Steam and damn Oculus :slight_smile: end of rant


Oh guys, this is a bit ridiculous…


Have you done a clean re-boot since changing the clock? Steam updates can get confused with timestamps that jump back/forth a bit. It’s possible with a windows clock change to get Steam updates sort of stuck in a loop.

This predates the rift issue. started yesterday @01.00 I reset clock immediately after your dire predictions :stuck_out_tongue:

1 Like

Wonder if we are due compensation ? I wonder how many rifts are out there :smiley:

1 Like

:slight_smile: Yeah, I don’t want to oversell the doomy and gloomy, it’s just more weird things happen if you have stuff that isn’t games on your PC. If you sign in on a domain, or have Autocad or a lot of online systems that use local windows time to sync, or a game with funky DRM like denuvo etc. it can just get a bit weird with the other errors you get. If you have a plain clean gaming PC it might all be ok to be honest, but I’ve personally been bitten on Win10 before with backwards-time changes so wanted to at least say something… :timer_clock: