Something SSDcrewy going on

#1

I’m struggling with an SSD the last 48 hours. My OS drive SSD got down to only 12GB free on a 500GB drive. And now it’s hit a wall and I’m having a hard time moving stuff off it. I’ve deleted a good bit of stuff off it, but if I try to move large quantities of data, it goes super fast until the cache (?) fills up and then it slows to a near stop. Is there any utility I can use to reorder the data on the SSD to clean it up and make it fast again? I know you don’t defrag SSDs but is there something else I can do?

I blame all the games and sims that put data in the users/documents folder (I’m looking at you P3D!)…

0 Likes

#2

You could move the pagefile off of it (if on there) or perhaps move your /users/(you) drive off to a bigger drive using a hardlink?

1 Like

#3

My Optimize Drives thingy in Windows is indicating that is has been 134 days since it last ran…did something happen 134 days ago that turned it off?

0 Likes

#4

Is that timeframe when you updated to 1809? Maybe that broke it?

0 Likes

#5

Hmm…might be. Does it need to happen for an SSD? It does look like it is NOT running on the SSDs…

0 Likes

#6

That does appear to be around when 1809 was released…

0 Likes

#7

I think that’s just the ‘when windows was installed’ base date (1809 rewrote lots of system files).

As I understand it, the Optimize is a defrag that wouldn’t help an SSD, so windows disables that for those by default.

1 Like

#8

So a very hands off approach here. The only time I ran out of space on an SSD and tried to clean it up with windows tools I had the same issue. The fix for that was apparently waiting a few days till the cache cleared? Sounds dumb, but after a few days it finally cleared and was perfectly use able, of course I had already purchased a new one by then. Maybe someone can explain it in a more technical way.

Kinda like when your spam email folder clears every 30 days etc

0 Likes

#9

Yeah…it’s really weird. Like I seriously hit a wall. Right now I’m trying to move (not copy, but move) my DCS folder to another drive and if I just try to move the whole thing, it says it is going to take days. Even to just move a 9GB folder it is running between 0 bytes/sec to 10 MB/sec…says it is going to take 2 hours and 30 minutes.

ssd2

0 Likes

#10

I’m guess it’s not on the same drive as your O/S, probably would have blue screened if that was the case?

0 Likes

#11

Actually it IS my OS drive (C:) but the computer seems to be running OK-ish (I’m getting hang ups on certain things…probably data moving problems). I just tried “copy” instead of “move” to another drive and it is still running like glue…

0 Likes

#12

The file copy box sits at 0 bytes/s for about 5 seconds, then pops up to about 6MB/sec for a few seconds, then drops back down to zero. And it just cycles like that. But sometimes stays on 0 for 20 or 30 seconds…

0 Likes

#13

So SSDs have a write cache but not usually a ‘read cache’ (maybe a small RAM one).

Perhaps try a Device Manager / Disk and find the SSD and disable the write cache (right mouse / Properties / Policies on it) to see if that changes something :slight_smile:

1 Like

#14

All of them have Enable Write Caching On the Device checked…I’ll see about deselecting it…

1 Like

#15

They should as SSDs need that, but for the one that is full or extra slow then try ticking it off to see. It that doesn’t help the maybe even putting it back on will help (like an off/on forced purge). I mean, it’s not going to get slower than what you are seeing, so worth a go.

1 Like

#16

It’s the same problem I have atm. I found I had 600mb of space left about a week ago. Deleted and moved everything I could find. Still not right but moving the page file from C drive to a 40gb ssd helped

1 Like

#17

Yeah, I let it run all night trying to move stuff and it hung up. Just shut it down and the two HDD lights on the front are doing something after my monitor shut off, so I’m going to just let it continue with that and see if I get a full shutdown after awhile. Hopefully it is doing some housekeeping. Wish my new build were on the way as this would be a good opportunity to do a wipe and fresh install.

0 Likes

#18

You know what the solution to this was? This was odd - I disabled Fast Startup from the power options. I have no idea at all why that fixed the problem. Currently moving my entire DCS install (100+ GB) to another drive and it is sailing along at 170 MB/s with no hangups.

Electrons.

3 Likes

#19

I’ve disabled fast startup a long time ago. I was scrambling to figure out why my PC would BSOD after whatever update re-enabled it w/o my knowledge (shakes hands furiously!), and I had to re-remember to disable it. My system just isn’t compatible w/ sleep mode, suspend mode, or any other quick start hibernation, including fast start. I like Windows 10, I really do, but these updates are ridiculously disruptive!

3 Likes

#20

I set my WIn10 system to update in the early morning while I was asleep but that ended up getting bypassed multiple times. About the only way you can take control of the dad blamed thing anymore is to never let it be online.

Wheels

2 Likes