SSD to Corsair MP510 960GB NVMe

I ordered this around Christmas, as it was on sale. I’m a bit ashamed to admit it, but I think it was about $160, but can’t remember and am too lazy to look. It took so long to UPS that I actually forgot it was coming. (hmm, this is turning into a sad commentary on consumerism, better move on quick…)

ANYWAY, I thought I’d write up my SSD boot drive to NVMe adventure. Starting now.

A tiny box. No banana for scale.

Wow.

Look at this huge pen!

Ok, time for the tweezers and a practice on Surgeon Simulator VR to put it in. It’s 960GB (a curious amount for those filtering in shops for 1TB) and is not as tardy as the cheaper Intel old stuff, but not as good as the latest EVO sticks. A cost compromise.

The first game will be ‘Find the NVMe holding screw that always gets lost when you open the motherboard box’, as this sucker doesn’t come with one.

I’m now off to clone my boot disk. I may or may not be back, depending if I can reset my password here once I lose my Windows install. Bye all!

6 Likes

If you need it:

2 Likes

I just think it’s a shame that little box probably bumped your Reverb off the delivery truck…

C8F30148-C65A-4BEE-A2F1-1E9BE62AC9F8

4 Likes

Ok, so it works. Here’s the benchmarks with using it as a boot drive for Win 10, plus my other standard SATA3 SSD’s for comparison (of various age):

Some thoughts so far:

  • Boot time is pretty much the same, as it’s not really I/O locked at this point but more waiting for things to enter different power states. About 4 seconds from cold to prompt, while maybe it was about 6 seconds before. Life changing. :slight_smile:

  • My big CPU fan made it huge pain in the ass to install. This is with the 2080 installed, you can just peek the first M.2 slot above the GPU

Here’s with the graphics card out - no room, so lots of sweating, swearing and general fumbling.

  • I had lost the riser for the motherboard. The one shown in the picture above (above the shiny PCI-E GPU slot) looks like it unscrews but it doesn’t. Oops, I unscrewed it pretty well, as it broke in two with a pair of pliers. :slight_smile: I found a spare screw and sort of jammed it in there. Sigh. Temps seem ok.

  • The Corsair SSD Toolbox tool the drive came with didn’t work, and was complete junk. Got about 5% through cloning the Windows partition and did a ‘Failed: Can not copy partion’. Yes, ‘partion’ was incorrectly spelled, which always inspired confidence of excellence in QA.

  • I ended up using the Free Macrium clone tool, and it was clunky, tried to upsell me, offered me a 1 hour timeshare apartment presentation I couldn’t leave, but it got the job done.

  • Once cloned, I took out the old SSD, went into bios, picked the MP510 as the boot drive and it worked as the new C:.

So far pretty underwhelming, but it was an ok price for 1TB (860GB in reality really), but I’ll move some apps on it and see.

3 Likes

It’s super irritating that M2 drives don’t come with screws. Like I can’t find the damn box for my mobo (if it even has a second M2 screw) so now I have to either source one or figure it out. Like ffs. They cost enough, just add a damn screw to the box.

4 Likes

@wheelsup_cavu could sure use for you to come over for dinner…

I had the same issue getting to my M.2 slot. Had to take the CPU cooler off and I wasn’t crazy about doing that on a brand new computer. But…it worked…and went back on without breaking anything.

Dat wood mayk me nervus two!

I have that too. It reminds me every time I close a program that it has taken something important out of “Focus” for me. I hate it. I just haven’t uninstalled it yet.

2 Likes

Hmm, super unscientific, but DCS feels smoother. It’s nice you can just move it without any registry highjinks - just needed to update the shortcut and start menu bits to the new drive.

4 Likes

That’s a nice Noctua CPU cooler you got there :slight_smile:

1 Like

For cloning hard drive partitions and everything related to it, I have on several occasions and successfully used the linux gui tool gparted. It does not explain every detail, but with a bit of background knowledge it can be very convenient and useful.

Using this and a few other things I pulled off several pretty cool things, including more complicated stuff like fixing boot loader issues, BIOS to UEFI boot conversions, increasing and shrinking partition size, keeping a valid Windows activation in the process, replacing HDD with SSD and so on. Stuff that is usually solved using a sledge hammer and much higher amounts of time.

I can highly recommend gparted and I trust this tool (and linux) a lot more than I trust some commercial offers trying to upsell on every chance they get.

For using gparted I usually download Fedora to a usb thumbdrive, then boot it and install the tool with this command: „sudo dnf install gparted“.

2 Likes

I successfully used Linux based Clonezilla boot media in the past:

https://clonezilla.org/

Guess I was lucky, then. I put my M2 NVMe drive in a good 3 years after I got the thing, but the M2 slot was along the bottom in between the PCI Express slots. I had to remove the video card but that was all.

My mobo/CPU is starting to age, it’s an i7-6700k I believe, but it has 32GB that match the board and all.

I just don’t think I’ll see enough improvement at this point to warrant it. Maybe in 2021 there will be something fast enough to make it worthwhile. I’m still GPU limited in most things I think.

© 2019 Mudspike.com | Articles Website | Forums Rules & FAQ