Voice Attack VAICOM Pro (now free) and DCS 2.8

Allright you got me convinced. Tax is done, next weekend I’m getting vaicom up again. Airio sounds awesome too.

1 Like

I managed to get this working again but it took me several tries.

It’s quite a dance currently. I’m pretty sure this will get sorted out now the source code is available.
What a chad move by Hollywood.


From Pene, one of the discord moderators, “ @everyone The first Vaicom Pro Community Release is now available, thanks to the community team for a long 24 hours of collaboration, hard work and laughs. :heart:


Well, I know what I’m doing Saturday morning. This is awesome.


cries in grad school

1 Like

I can’t seem to get Viacom to install at all. The link in the PDF doc gives a 404. I got an .msi installer file from Github, but when I click on it nothing happens…

I did the manual install from the zip. Extracted it, and then copied over my existing install. Inside the the zip archive is a folder named VAICOMPRO. Place that into your \Program Files (386)\VoiceAttack\Apps folder. In VoiceAttack, click the wrench icon and on the General tab, check the box next to Enable plugin support. Restart VoiceAttack, which will create more folders within VAICOMPRO, attempt to locate your DCS folder, and copy/modify files in both your DCS.openbeta and Saved games\DCS.openbeta folders.

Also, inside the VAICOMPRO folder is one called Documentation, where the manual (not updated yet) is. Carefully work through the first 5 chapters of the manual, which are the most critical. It will seem like a lot to take in, but really worth the effort in the long run.

Edit: Clutch, I see that you are chatting on the Discord server, which is the best place for support.


Yep I think I have it all set up. No time to test actual comms before sleep though I’ll get to that tomorrow. The only hiccup I’m finding so far is the config window stuck to “Easy communications: ON” even though it should be off. Haven’t found any successful troubleshooting on that one yet.

1 Like

I see that too, although I wonder if that is the default and it will change once you are hooked in a mission with Easy coms off. Never bothered to look at this while flying since I’m usually in VR.

One of the gotchas is not importing the command set after adding extensions like AIRIO. That is done via VA > VAICOM Config > Editor tab > Finish button. The pop-up instructions could have been written a little better. Took me a while to get my head around that one, but it is easy now. I use an interim step of pasting the keywords in notepad++.

Pro tip: In the VAICOMPRO folder, there is an executable called VAICOMPRO.exe. If you launch VoiceAttack with this instead of the usual way, it will load the VAICOM profile, and more importantly, restart VA if it crashes while flying. Sometimes VA becomes unresponsive, for what ever reason. I just peek under my VR headset and close VA. Then go back under the hood. It will restart VA in the background, usually fixing whatever was hung. It runs in the system try, so when you are ready to shutdown VA, you can click it for a contextual menu that offers Exit.


Sounds like it may have been file/folder path issue?

If so this may lead me to an solution for my issue with the network connection.

1 Like

FYI, after work today, I removed the patch, set the custom game path and sliders to the correct folder and version, and set file management to automatic. Everything seems to be working perfectly, including the Interactive Kneeboard. Rumor is that setting the Custom game path to the actual main DCS folder fixes that. Also, I found that somewhere along the way, I had turned on Easy coms in DCS. Unchecked that and now VAICOM is reporting that correctly. Brilliant work by the Discord team.



This is what my PTT window shows in the F-14, even shows which radio I engage with the comm switches, but still says easy comms on. I’ve verified it’s off in DCS settings and in the .miz file options. Maybe it’s just a glitch with 2.8. I haven’t gotten much troubleshooting response on it. I’ll try the viacom exe instead of VA next time and see what happens.


I wiped my VAICOM install and installed the community edition from the github. It works really well with the install instructions from their Discord:

  • Backup your current VAICOMPRO folder found in your VoiceAttack/Apps folder.

  • Backup your current VoiceAttack profile by clicking “More Profile Actions” (button right of the edit in VoiceAttack) and exporting your profile to a known location.

  • Delete the VAICOMPRO folder in your VoiceAttack/Apps folder.

  • Launch VoiceAttack and exit VoiceAttack.

  • Unzip the contents of the zip file and move the VAICOMPRO folder into your VoiceAttack/Apps folder or run the msi installer.

  • Launch VoiceAttack and exit VoiceAttack. This generates the necessary file structure within the VAICOMPRO folder. If using the msi installer, drag the AIRIO and CHATTER dll files to the VAICOMPRO/Extensions folder.

  • If you wish to restore your VAICOM settings, copy your backed up Config folder to your new VAICOMPRO folder in VoiceAttack/Apps. Your profile should remain in VoiceAttack as it is stored in the VoiceAttack.dat file. If your profile somehow gets changed, import your backed up profile.

  • Launch VoiceAttack and launch the VAICOM config menu (L CTRL+L ALT+C) and open the “Config” tab. If this does not work, check your VoiceAttack profile and ensure the command “Configuration” exists and is enabled with the proper shortcut.

  • Check Fix Reg and move the sliders to match your DCS World version (i. e. openbeta / standalone).

  • Next to “Use Custom DCS Path” click the SET button and direct it to your DCS World install folder (i. e. Program Files/Eagle Dynamics/DCS World OpenBeta).

  • Open the “Reset” tab and uncheck all of the boxes.

  • Check only the “Lua code” box and click “Master Zero”.

  • Restart VoiceAttack and check the log that comes up, to make sure it finds your DCS 2.8 installation


I’m having so much trouble with the software I’m glad I waited for it to be free instead of buying it. The Microsoft voice recognition is garbage compared to what VoiceAttack uses natively. I can have the exact same command in both VA and VAICOM, where it works perfectly in VA but turns into gibberish in VAICOM. Can’t get Jester to tune the radio in the back seat at all.

1 Like

Interesting. I bought them both together and have never used VA separately. Ya learn something every day. I may skip VAICOM Pro this time (once I get around to setting it all up again) and go straight to VA profiles…can’t be any worse :slight_smile:

You might make sure that VSPX Speech Processing is turned off in Vaicom preferences. By default it should be off, but I’ve tried using it and had a similar experience. The default MS speech engine (which Voice Attack uses by default) works best.

Hey Clutch, I know that you are very technically aware, but did you follow all of the setup tweaks in the manual? You probably understand it better than I do, but I’m having no trouble at all with the community build. Granted, sometimes he misses a call, and it does seem that Bailey’s VA profile was more pronunciation tolerant than VAICOM. No one would blame you for sticking with that if it works better.

This helped me with learning Jester commands:

I really love the Interactive kneeboard, Realistic ATC, and have learned the VAICOM language enough that I’d hate to learn another. The Kneeboard keeps a running dialog of coms, including clearances and BRA calls. I’ve flown a number of missions that last few days and really having a blast.
with VPro.

I don’t remember having trouble telling Jester to change channels, but I might have been using the Select command (manual page 19). You’d think that there would be a “RIO, go button x” command, but I don’t see one.


I’ve tried all the tweaks, and after hours of adding set phrases, recording them, adding words to be ignored, and reducing the minimum confidence to 30, I finally got about half of it to work. It still goes off the rails sometimes.

When it works I do like the Jester wheel and radio menu being hidden as well as the instant comms response, but I wish I could say the full phraseology and still have VAICOM execute the command. If I say “204 marking moms 090 for 50” it thinks I’m trying to hail #4 wingman. If I say “marking moms 090 for 50” it will recognize “marking moms” but not execute. If I omit the phraseology entirely and just say “marking moms” it works :man_shrugging:

I also keep getting “awaiting additional input” with some commands which, according the manual, means I gave an incomplete command…except also according to the manual the command I gave is a complete command. “Texaco approaching refuel” --recognized-- (awaiting additional input)…so frustrating.

That sounds like @WarPig is right and you’re trying to use VSPX and its natural language processing feature.

That never worked for me reliably. I have VSPX deactivated. In that case you have to make a pause:

“Texaco” …
(Awaiting additional input)
“Approaching for refuel”

You also must not add own words like the vector in your other example.

1 Like

I never tried the VSPX, only the Microsoft speech recognition. I thought I was pausing, but perhaps I wasn’t pausing enough. What seems like two seconds to me can end up being two microseconds when I listen to a recording of my voice in other situations.