Voice Attack VAICOM Pro (now free) and DCS 2.8

Have you tried activating the control sound? I found this helped with timing the pause.

I haven’t done the speech recognition training since upgrading to Win 11. Not sure that it matters, but I should probably run through that a couple of more times.

This caught me eye: I’ve always had better luck that way; making things short and concise (in the software’s mind that is). Seems there’s a bit of compromise required here. Would be nice if it worked as expected but my experience is OS speech recognition in general is still a bit off. Even the SR in my wife’s new car is more annoying than useful.

IOW, I’ve been a promoter of this gizmo (VA+VPro) for some time but have never used exact phraseology; I’ve had to bend to the limitations of the tech.

VSPX never worked well for me either.

This helped me in the beginning. In fact I’ve gotten so use to it I leave it on all the time and really don’t notice it anymore.

1 Like

I think that’s a feature, not a bug. Vaicom doesn’t expect extraneous input added to the commands (not that IRL the bearing/distance would be, but to Vaicom it is). I think the only thing you can add is your callsign, IIRC. I actually don’t normally, and will have to try that when I get home and see how it works. The Vaicom kneeboard commands (and the one for AIRIO) are absolutely invaluable to me.

The Vaicom kneeboard itself (which I’m sure you know can be browsed with commands like “showpage: ATC”) also has some of the pertinent commands displayed on it, which I’ve found very helpful. I haven’t encountered the problems you’re having, and feel sad that you have. I will say, however, that although Vaicom recognizes my voice with 95% accuracy (pretty good, I think!), it doesn’t always work the first time when other people try out my sim. I’m not sure what the issue is, except that maybe MS speech has learned my voice.

I think I have that enabled; the beeps that are heard when it recognizes a command?

I’m not sure Windows speech is actually learning anything on my machine. When I go through the trainer I have to train it to recognize my commands by adding and recording the full set phrase. After that sometimes it works sometimes it doesn’t. When it doesn’t work I have to add a list of words to the ignore list after watching what extraneous words it picks up. and then it will finally get the right thing. Then when I’m up in mission it struggles with low confidence rate on the same phrases I literally just programmed.


From Pene on Discord, reposted in case some of you have over 37 aircraft (they suspect) modules activated.


Work and testing on bug fixes and module integration continues and the Dev team are making good progress.

The Beta Test Team has been established and thanks go out to those that have offered to give up their time to help the Vaicom community, they can bs recognised by their seperate role on this Discord.

During bug squashing we have identified an issues with UDP packet size buffers being exceeded when the users system has 38+ modules installed. This causes erratic behaviour in Vaicom and appears to be a contributing factor in multiple bug reports.

Can I ask that if you are experiencing issues with Vaicom, when lodging your bug report do a quick test with modules deactivated in the DCS module manager to bring the total installed modules below 38. Then see if the behaviour has been rectified prior to reporting, or if already reported update your GitHub issue.

There is a fix for this issue in the works, and thanks to
Folgers and Special K for their relentless pursuit of this bug. No timeframe at this stage as there is work and testing to do before we release the next Vaicom update. In the interim deactivating modules via the DCS module manager to bring them below 38 (I.e max 37) will stop many issues.

Everyone have a bandit week :metal:


Looks like that was my issue. Weird that the software suddenly does wacky things once you get 38 modules.

I also noticed that vaicom can cause replay track issues since it bypasses keypresses, so if you do any command that would normally be through the comms menu, it doesn’t actually get logged in the replay system, and thus doesn’t get reproduced in the track.

Otherwise it seems to be working pretty well.


Wow, that explains why my replays never work!


It might only be limited to those modules that need ground power, air supply, or cranking the inertial starter. I found out in the Bf 109 when, in the replay track, my engine never started and my control surfaces were moving like I was flying despite being on the ground :rofl:


For me, it’s always “Chief, remove the wheel chocks” that didn’t work, same story. So every time I got splashed by the last remaining bandit in a two hour Raven One mission, I couldn’t just replay it at 10X speed to get back to where I was. Now I understand! :melting_face:

1 Like

I just ran into the module limit issue. It was putting me in coms menu hell in the Spit and preventing me from starting the Beware Beware campaign, because I couldn’t give AI orders. I tested a bunch of missions in a few different modules. The confusing thing was after about 5 mins into a mission in some aircraft, like the Hornet, it would begin working. I’d think that I fixed it, but go fly another mission in the Spit, and it would be bollocksed again. Special K though that it might be a module count issue, so I disabled 10 aircraft modules that I hadn’t flown in a while and it’s working perfectly again. They say that they’ve identified the culprit, but haven’t released an update yet. Great to know what causes it.

1 Like

I’ve got so many hangar queens I should give that a shot. For me the bug manifests as a dead mic every other time I key it, so I have to say everything twice. Did you just click the toggle switch in the module manager, or the trash can icon?

That made me think of the hospital scene in Catch-22.


It was doing that for me as well. Now the misunderstood phrases are the exception.

In the mod manager I toggled the slider for the modules that I wanted to disable, then clicked the X in the upper right hand corner to close the window. That prompted me to restart DCS.

1 Like

It’s something like 34 right? Hmm, I don’t think I’m close to that…curious…ok, I’ve got 23. That includes maps and such - everything without a “buy” button on the bottom of the entry page. Guess I need to get with it :thinking:

Ostensibly, it’s 38 aircraft modules. But it’s still unclear if other modules, like campaigns, go against the count. One day they do, and then next they don’t. Also, there is the question of how many are included in FC3 and reports that Tacview should be counted. Here was my count when I began having issues, and keep in mind that I had the A-4E-C, UH-60L, A-10, and OV-10 installed. You know that little Sea King pack that you put together? It shows up as a module in Module Manager.

Mine totals out at 53…so I guess we need to get that total number to 37?

That is the consensus. Will be a good day when the squash that bug. I wonder if the original author knew that there was an problem, but couldn’t determine the cause. It must have been frustrating trying to support it single-handedly.

Yep, disabled some modules (including mods like the A-4) to get down to 37 modules, and now it works well. Except for VAICOM not understanding that SC module owners get SC comms on the Forrestal, so I can’t make any calls after Marking Moms :frowning:

1 Like