VPC MongoosT-50CM2 Base USB Connectivity Issue

Hi guys,
Im new to this forum and a proud new owner of the VPC MongoosT-50CM2 Base, Mongoose Grip and the CM2 Throttle. I eagerly setup all my devices yesterday. When updating firmware I inadvertently had both the base and the throttle connected. The throttle is all set but now my base will not work. When i view my device manager, I have a yellow triangle next to the device (CM2 Base) and its shows the following error:
This device cannot start. (Code 10)


Ive tried multiple computers in my house and even swtiched USB cables with my throttle to no avail :frowning:
Has anyone else had this issue? Can someone please help?
Thanks in advance.


Hi @cloud and welcome to Mudspike! :mudspike:

Do you see the base in the VPC software?
Unplug everything else and look for something in the device list there.
Make sure it’s the base by unplugging the USB cable and plug it in again.
Then try to update its firmware and add a profile.
Let me know if you need more info on how to do that.
Here’s the latest VPC software.


Cloud , take a look at this link if Trolls steps do not resolve your issue. His way should work, but just in case here is a link to the VPC Troubleshooting page. IF you still have issues, just let us know, more then willing to try and help you resolve this my friend.



I would try @Troll’s suggestion first to see if your base shows up in the VPC software first. If it does, you can most likely flash it again. If it doesn’t show up, make sure that you have not set the software to only see VPC hardware. That setting is hidden under advanced settings, which can be toggled with CTRL-F12. Set to show all devices, not only VPC, then try to flash.

If that doesn’t work, you might try this fix to change the driver. It’s for the Logitech G27 wheel, but will help you understand how to force a driver change in Windows 10.

@JunkYardDog’s like to the Havoc Company is a good one and pretty much everything that I know about setting up VPC software comes from their YouTube channel.

You can also ask for help in the VPC forum.

Let us know how it goes.

1 Like

Hi guys,
Thanks for your quick response. I was able to open up my CM2 Base and re-flash the bootloader as described by Havoc-Company as seen here on this video: (thanks JunkYardDog)


Its pretty crazy that id have to go to these lengths to fix a problem that seems almost easily avoidable. If you update firmware via Virpil Control Center with multiple Virpil devices plugged into your USB, it will brick your Base. The base will then show up as broken in your device manager as:
This device cannot start. (Code 10)

The ticket I opened 3 days ago was responded too with a “please check your USB cables and make sure they are connected properly” a bit more complicated then that guys lol

I suggest Virpil update their software with a huge warning that says “Update firmware on one “Virpil” device at a time or you risk breaking the firmware”

Again, thank you for your help. Much appreciated!


To be fair to Virpil, the software warn you about this when you start it up.
That said, I have updated the stick base when the throttle was plugged in and vice versa, and never had a problem.

Glad you solved the problem though! :+1:

1 Like

That is fantastic news. Glad it was a reasonable fix. It still stinks you had to deal with it, but its not very uncommon and in fact something I comment on several months back on another forum .

A user had a very similar issue and the excuse given was its to be expected with such “High Demand” and fast growth. I merely made a point of stating one thing I can tell you that is a axiom of production based business…

" The fastest way I know of to cure the issues of quality that come when a business experiences high demand, is to offer poor CUSTOMER SUPPORT to go with that defective product."

They are improving, I will say that, but that is relative to where they started.

I digress though , I am just glad the situation worked out in the end. If you run into any other PC issues like this , feel free to post or hit me up. I will try to help, kind of a hobby to me, is helping people with PC problems.

Cheers !

P.S. Now if I can just get wwwright (Bill) to let me know if he solved his TRIM issue with the F/A-18. :- :grin:

I have have had technical problems with one VPC MT-50 base and the Thrustmaster TPR rudders.
VPC told me to RMA for a replacement, immediately.
TM did the troubleshooting routine for several days, one reply per day and then asked me to RMA the unit.

The problem is this though, you are a exception to the rule. The Forums from reddit to theirs has so many similar post. With one guy still waiting for 8 months now on his RMA.

The fix is so astoundingly easy its hard to fathom why they have yet to do it. Just , in some fashion, put a couple of warning labels made from paper and with a decent sized but plain font ( For Simplicity and low cost) on the BASE, the END of the USB Cord , and then you have the one on the software already.

That puts the onus back on the user. People are excited to get a product such as this, and get in a hurry and can miss a simple SOFTWARE warning in the rush to get it up and going. That is just “HUMAN NATURE” , and it would be such a simple and cost effective fix to have a few warning labels as I described. The time and expense required to offer customer support is far far higher than the cost to prevent the need from this issue all together.

It would help them as a business, it would help the customer , and it would pay for itself long term. Everyone wins.

I always thought nobody is rich enough to afford or lucky enough to get multiple devices from their limited supply in the webshop :stuck_out_tongue:


Probably not, though.
All those users that don’t have this problem doesn’t post about it…
And I’m guessing they far outweigh the users that are experiencing problems.

Of course the do, or they would not be in business. Fact is, if you have say a 10% error rate in a business, and you do not address it, It will, in the end, hurt your business. For every post, its a common given in support business, that there are 3-4 that do not.

To say I made 10 widgets, and only 3 are bad, is not a good business plan.

They are brilliant Hardware Engineers in every sense, and have the best product, but so did some one else before them. I really like the lead engineer, he plain tells it like it is, and makes me laugh every time he does.

They are VERY Concerned with the future economics of their Business right now, and he flat said he had NO IDEA , when speaking on a new product , IF or when it would ever hit the Market, as he doesn’t know if their will be a market or a a Virpil.

They have a rep though, of this type behavior, and I would see them succeed, and to NOT say “hey guys, you need to look at this before it gets to out hand,” would be rem is on my part. I do Support all day, usually 7 days a week, when I am not doing In House or Very early Beta work for Software Companies.

I have seen those on top, hit rock bottom in a hurry over my 25+ years of it, I would not see that happen to them if I could help it. Telling them they have a issue, is just the TRUTH , and may help them.

That’s the point I tried to make. :slight_smile:
I just found your remark about me being the exception to the rule, to mean quite the opposite.

Lot of that going around, these days.

I knew Baur and mega-mozg before they joined Virpil.
It’s a small company with some really great minds.
Coming up with a design and setting up a production is one thing. Managing the product after it hits the market, is another.
Obviously mistakes are made. Product support is expensive.
I do agree that they need to do better in this regard.
But I do not agree with the ridicule they are getting.
I want to use high end flight controllers. I realize that I have very few options and I try to support the ones I have. So I’m prepared to cut them some slack, regarding the problems they’re facing. Especially since my experience is not any better with the larger brand.

Dealing with these kinds of after market problems is my worst nightmare, for my own production. I’m going to label my stick “no warranty” and sell it at parts and material cost, just to avoid it. Not in it for the money anyway :slight_smile:

1 Like


because they got the design aspect down, and its a blessing and a curse for them to be so busy , that they have not time to find someone to help. that sounds simple, but when your talking about what they are doing, and the size of the team, the person chosen to do the product management as far as the consumer goes , has to be someone you can trust impeccably , and also MUST fit into the tight knit group that these small hardware and software teams are these days.

That is no small task to find such a person for sure. With little to no time free to even begin to look its understandable, I just hope the success and the hectic production rate they have does not completely blind them to the need of such a person for their company. Its would easy to have happen, as you when you are so busy in work as they are, time just eludes you. You look up and 6 Months have vanished and you are not sure where.

Its a need they really do have to consider addressing very soon, in my opinion. I think a small delay on top of what they have now, hurts far less in a business sense than a longer term of trying to do support in the fashion they are. Thats no fault theirs really at this point, but thats irrelevant to the overall grand plan of HOPEFULLY surviving this nightmare and coming out the other side a stronger and healthier company.

Hell , I just hope we all come out the other side of this damn plague. It was bound to happen , I just wish my children did not have to live it.


1 Like

I saw the warning that popped up. However, I guess I read “we recommend disconnecting all other devices for safe profile setting” as “other” being my xbox controller, my trackIR or any other device that showed up in the Virpil software window. Whooopseees!

lucky enough :wink:

Thanks again everyone. Unfortunately, seems im not quite out of the water just yet! My throttle is working just fine. My grip is still having some issues after I reinstalled the firmware. I’m getting no button response and some strange errors have popped up. Number 1 and Number 2 AXIS has errors. Link 98 to Link 104. As you can see from the pic.

I think it says something like ”you have multiple VPC devices”. But anyway, I’ve never had problems with it.

Don’t you have a CM2 base? Seems like you loaded a CM profile?
The LEFT and RIGHT are just additions in case you’re using two of the same controller. Many space sim flyers do. Just to keep the sticks separated in the sim controller setup.
You don’t have to specify a side.

I do have a CM2 Base. When I select CM2 it names it CM. Not sure why. This is extremely frustrating.

I’m guessing you need to force the VPC config software to the controller board that it has. It’s in that havoc company link, above. I can help you out later.