X-Plane 11.30 Beta...

So how are you guys getting along with X-Plane 11.30 Beta? I’m having some problems that appear to perhaps be scenery related. Everything was working fine this morning when I was using some United States airports. As soon as I moved to Europe airports, I get an instant crash when the scenery is trying to load. Unfortunately, the LOG.TXT file is not really helping…

Going to try going with a clean custom scenery directory and see if I can sort out what is going on…

I’ve only tried it with stock scenery so far, and it seems much smoother. I plan to try the Zibo 73X stuff soon, but so far just stock aircraft as well.

I’ve had quite a few crashes though, especially using things like the ATC. Things like the new ‘File Flight Plan’ dialog are also broken in VR in that you can’t pick Aircraft/Model from the drop-downs, meaning I have to switch to 2D, file, and then switch back.

For a beta 1 it seems ok, but a bit rough. Looking forward to beta 2.

1 Like

My insta-crash is definitely related to my massive scenery library due to the fact that removal and incremental adding of files has worked thus far. Thankfully, scenery files are easy to put in and take out, and I’m relieved it isn’t a plug in or lua file causing the problems.

One thing that discourages me from changing things in xOrganizer too much is that it seems to trigger the license key revalidation each time - it’s a huge pain, especially in VR because I have to dig out the email, copy the serial, try to paste it in in VR, complete PIA.

Does that happen for you as well or am I ‘special’? :slight_smile:

Interesting - I’ve seen some license triggers - but almost always exclusively for X-Aviation products (SkyMaxx and Real Weather Connector). I don’t think it has caused license reactivations for other products (aircraft). And my X-Aviation license just says “license automatically updated” and it does’t appear to do it on each run of X-Organizer. Hmmm…

Yep, I’m just talking about plain X-Plane license key reactivations, like changing my scenery.ini or something seems to trigger having to re-enter it pretty much every time I start up.

I think I might reinstall from scratch, something must be up.

EDIT: Reading around it’s probably because I use VPN connections, and that even a change in IP or adapter use between runs will cause the serial number entry every time. Jeez.

Funny though, because I just ran X-Organizer and then switched to the JustFlight Hawk and got the license reactivation! I wonder if it is particular plug-in types that do that…because I don’t always get it…

But my X-Aviation licenses didn’t have a problem with it.

Oh, I got you - the actual X-Plane 11 base program reactivation - no I never see that when using X-Organizer…

1 Like

I’ve been doing a lot with the Hawk in LAS recently. I just love the desert and the strip in X-Plane and find both to look and perform considerably better than in NTTR (DCS). When I updated to 11.30, it would no longer load. I knew before this that my 16 GB was starting to bottleneck. So I took this as a sign to gauge up to 32. After that I’ve had no issues. There is a dull troll fight over at X-Plane.org (<— not a direct link) about whether FPS has gone up or down with 11.30. Exactly half the respondents say it’s worse and the other half say better—often with members of both groups using very solid methodology to get reliable numbers from both versions. Personally, other than the aforementioned LAS crashes, I cannot tell a difference performance-wise.

It’s beta as we all know. But worse it’s beta across Win, Lin and Mac. That’s a mind boggling number of iterations to get right.

2 Likes

And I can confirm, each time I run X-Organizer, the JustFlight Hawk asks for a serial number once again. That is a pain in the butt…and I don’t want to burn through any activation limit (I don’t know if there is one, but I would think if they get a flurry of them they might disable that serial…)…

I doubt it. But since your are basically “x-organized” already, can’t you just disable the plugin until things get sorted?

Well, I could just not use the Hawk until I get it sorted…but I’m also running up on a deadline for the magazine to write about it, so I’m trying to use the Hawk and troubleshoot the beta problems. Probably best to tackle the beta problems (I can probably resolve that tonight) and then load the Hawk again. I probably should not have upgraded to the beta right before my article deadline… LOL…

2 Likes

What’s life without living on the edge, eh?

(But I’m sayin’ just dropkick x-organizer for now until it and x-point-thirty can play nice together. The beta is not an issue. I put in about 10 hours over the last 3 days. I know…sad.)

1 Like

Looks like there is a beta update today:

https://www.x-plane.com/kb/x-plane-11-30-release-notes/#Beta_2

1 Like

Cool!

@near_blind might have to change his drinking plan with this fix:

  • XPD-9548 Blackout during climb in FF A320.

:slight_smile:

1 Like

Beta 3 is out!

I actually reported XPD-9579 for this one a couple of weeks back and it got fixed.

The system works! X-Plane Bug Reporter

:slight_smile:

1 Like

What was a filtered drop down? A menu?

The new ATC dialog in VR wouldn’t work, because the ‘Manufacturer’ and ‘Model’ fields were drop-down boxes to pick from - they couldn’t be activated in VR, meaning the feature was stuck as the flight couldn’t be filed.

1 Like

Oh yeah…I do remember you mentioning that! I haven’t even tried ATC in VR yet. Does the X-Life radar map work in VR? I’ll give it a shot this weekend…

X-Life seemed to have a problem with Oculus, as it killed performance since v4 in VR, so I haven’t used it in a while. I guess since this is SteamVR now it might be worth another shot.

I just did a YVR -> KSEA via the JAWBN arrival to 16C and the new X-Plane ATC actually worked ok in VR. Hand-off to controllers was good, the new speech output worked well (the only new bit I think) and the only bug I found was in the Tower hand-off to Ground at arrival - I think all those parallel runways at KSEA confused it. Apart from that, it was nice to set up some AI flights and hear the chatter.

If X-Plane added some VFR ATC then it would be pretty good all-round.

1 Like