X-Plane 11.50 issues

So, with X-Plane getting Vulcan support, I thought I’d give it a go.
Earlier XP wouldn’t even start, unless I lowered my OC to below 5GHz. Now it starts, but hangs on exit. Ok.
What’s worse is that the pitch trim is stuck on up. I’ve checked for bindings and I have bound it to buttons and axis, which can control the trim, but once I let go, it trims max up again.

I want to like XP, but I always seem to encounter an issue that gets in my way…

3 Likes

Same here. I have the same problem with elite dangerous as well.

I want to like it. But it throws up roadblocks

That’s too bad @Troll. Outside betas I’ve found X-Plane to be pretty dependable in the 15+ years of using it. Having said that, I have also been suffering from the hang-on-exit issue. Sounds like the trim has somehow mapped itself to an axis.

2 Likes

This DOES happen. Occasionally, when I’m changing controllers, x-plane will automagically assign an axis. For me it was my Razor Nastromo being assigned to the rudder axis.

BTW, I installed beta 3 this morning and am now experiencing almost a doubling of frame rate in the TBM900.

1 Like

If you are getting a hanging exit with VR it’s a known issue, I get that also in 11.41. The 11.50b3 on steam came out last night, I tried it and haven’t had any issues. Massive performance increase.

3 Likes

Ok! Good to know.

That, or a stuck button…
But I can’t find out which one.
When I map it to an axis, that axis will override it, but when I stop moving the axis, the ”trim runaway” takes over.

I believe there is also still several aircraft that will not work in 11.5. Lots of little bugs and texture issues as well. Very dependent on user hardware and settings. I’m impressed so far with the progress that has been made in this first week. X-Plane has been my new found Coronatine hobby. Owned for several years and never got into it until now.

3 Likes

I do to…

I see Mr. Myer getting all excited about Vulkan and textures and whatnot and I want to scream. He will put that much work into the visual but none into ATC?

All I want is to get permission to taxi, take off and land VFR…that’s all…is that really asking too much?

I’m sure Vulkan is great but I flew sims with 4-color VGA graphics on a 12 inch TV set with FPS under 10. (I also walked to school in heavy snow …uphill both ways…so…).

2 Likes

I guess you have tried it and it is happening on multiple airplanes even default.

1 Like

Yep.

Did you try the calibration within XP joystick settings?

I did. In fact, this happened on the first attempt, before I assigned controllers and just used the VR controllers, too…

Reinstall :slight_smile: (sometimes it can help)

Yes, it seems like the only option left.

This is still Beta? Correct? I don’t have to load it?

1 Like

Did you try to check the Log.txt file? Maybe, just maybe something in there.

11.5 is in beta. If your on steam you have to opt into it to download. Not sure how it works if you have standalone installer.

The beta version is only 2-300 mb of changes. I’ve flipped back and forth two or 3 times.

I do have a Steam account but not for XP or DCS…

I do the DCS Beta because you kind-of, sort-of need to if you want to play with the new releases…I don’t feel that way for XP, so I will probably wait until 11.5 comes out of Beta

1 Like

Yeah, thats what I’m doing. Switched to beta to see how it was doing and switched back.

© 2020 Mudspike.com | Articles Website | Forums Rules & FAQ