X-Plane VR and Vulkan Beta Tid-Bits

So, with the potential Mudspike Air Cargo (MAC) launch, I decided to get back into the non-DCS stuff. XP’s Vulkan beta sent me over the edge - it allowed me to use VR.

Taken a couple of days of messin with it (I’m done with P3D btw - need to stick with one; at least until FS2020 blasts off. With VR. And good performance)…

Performance strangeness

First here’s my specs: i6700K at 4.4Ghz, 32mb Ram, nVidia 1080 w/8Gb, SSD, Odyssey + VR.

Default C172 and B738 used for this around KPHX area, overcast skies.

I’m not getting into all the possible tweaks here (plenty of that elsewhere), just some things I’ve noticed. And due to the number of possible combinations of settings + configurations, none of this is real low-level. There’s a LOT going on behind the scene’s with these sims & systems…

Running from a HDD vs SSD
Didn’t notice a huge difference (I did in DCS), beyond the initial load. Some, but not huge, though this may relate to Number 1, below.

Interesting Thing 1:
Number of World Objects & LOD (Level of Detail - how/when geometry is rendered base on, mostly, distance from viewer)

Applied both the [Settings | Number of World Objects == Max], and via [AviTab (I think it was) | LOD == max]. It took it like a champ.

Note that the FPS went down but, here’s the kicker, it ran smoother?! With the above both set to middle-ish (for my system) it was a bit more ‘choppy’, but with higher FPS. Only mention this cuzz, well, give it a shot? May be the way objects are pre-loaded in Vulkan vs OGL.

Interesting thing 2: When it gets choppy, in the C172 anyway (if that matters), it is more noticeable looking LEFT than looking straight ahead or to the right? Really weird. This is all at low altitude. Sticking my head through the left side window (come on, you know you’ve done it) actually seemed to help. Maybe a texture issue? Just strange.

Took to using this as my quickie-visual-benchmark. I’d even lean over close to the right seat window and look out. Same thing, smoother. And yeah, I had to stop myself from putting my hand on the co-pilot seat in VR :slight_smile:

Night Flying
Did my first VR night flight (KPHX…KFLG). Light not so great. So I found this and much better: “Better lights x plane 11”, at:
https://forums.x-plane.org/index.php?/files/file/36455-better-lights-x-plane-11-v2/

Annoying, Night Vision-spoiling, 3D mouse cursor in VR.
Wanted to kill that thing; imagine a LARGE moth, that glows!, flying around inside your cockpit. Once everything is ‘in the mood’ [lighting], and your eyes adjust, that dang cursor is a real distraction.

You can move it out of view but after about 3 seconds it jumps back to the edge of your view. Grrr. So, I’ve mapped a button to turn it ON/OFF: “Toggle the 3-d mouse cursor in vr”.

Just have to remember to turn it back on if you exit to change stuff in the Settings. Not much luck with a better solution yet, like making it Red, or something?

3 Likes

Next…
Seems LR came out with another Vulkan beta today. So, I dug in…

Interesting Thing 3 - “Don’t Mess with it”
Performance was getting worse. Was down to mid-30’s and not smooth in my testing scenarios.

*There remains one odd thing I’ve not solved and it seems a Windows 10/WMR issue, see below.

So, I basically cleaned out ALL tweaks I’ve made (really only a handful, not too drastic); it’s X-Plane outta-the-box. No Lua stuff beyond the what you see here (the top 2 are my additions, the others I’m not sure where they came from - LR?)

image

FlyAgi-Tweak_Utility (which requires: FlyWithLua ) ended up, well, just getting me all discombobulated in the end. Even though the settings I tried reduced things it was running worse.

Here’s my XP Settings | Graphics, FWIW:

Not too high but ya know, it looks fine in VR - if I lean Right on the World Objects I can’t really see enough “ooh, ahhh” there to warrant the FPS drop, if any. Average 45 FPS and smooth; overcast, thick forests, etc.

It’s almost like (and they seem to have hidden some 'tweakable’s away with Vulkan) they have tuned it for exactly the defaults. Makes sense. As I understand Vulkan, along with my long-ago 3D graphics programming work, the fewer branches the better; bend over GPU here it comes and trust me, nothin’s going to change. So you can go full blast!

Way back when (first OGL/D3D API’s) it didn’t hurt so much (really a lot of caveat’s here though) to change stuff in the loop cuzz it was expecting new stuff each frame, nearly. Don’t think this is going to be the case any longer? Think cache lines I guess.

So, for a while at least, I’m not messin with anything outside the sliders.

Windows 10/WMR Shenanigans
When I plug in my WMR headset (O+) the desktop ‘blinks’ and I loose most of my shortcuts!? I’m several hours into this furball. Along with this, and related I guess; I suddenly have 4-5 other Display’s: right-click desktop | Display settings and I get this:

image

I only have one monitor. In the above I’ve had to then select 2 - 4 and select “Disconnect this display” to get my shortcuts back (or on one single desktop) - every time!

Here’s a link to the only thing I’ve been able to Google-up, which describes it exactly:

https://www.reddit.com/r/WindowsMR/comments/fd77k9/new_desktop_shortcuts_disappear_when_wmr_is_active/

Any clues?

[Edit] Ah HA! Found it. Not a cure but it’s a known thing:

“…During Windows Mixed Reality sessions, virtual monitors will appear as generic physical monitors in Settings > System > Display…”

https://docs.microsoft.com/en-us/windows/mixed-reality/new-microsoft-edge#known-issues

Smooth Rides
JR

2 Likes

Yeah, I’m running from an HDD. Other than saving you some loading times, I haven’t really seen anything significant as far as in game performance goes.

X-Plane is an odd, odd beast. Sometimes you can up the rendering options and get better performance. Sometimes you can reboot and it will tank after that. I’ve never figured it out.

I’ve also seen something I think that is related to Vulkan - when I first start up, sometimes my cockpit textures might be a smidge blurry. After a minute or so, they snap into sharp detail. I think I read somewhere that Vulkan does some background stuff and that is something that can happen. I’ve definitely seen it…but the smoothness after everything is cached or loaded is very nice…

I’ll have to try that one…good find…!

1 Like

Yeah…I saw that released and X-Plane prompted me to update and I’ve skipped it for now…

Got dat write!

In the process of fixing my issue (see above a couple of posts; a wall of text of instructions I had to go through but it has worked), I had to UN-install then RE-install ‘stuff’ (drivers, WMR portal, etc). And guess what? X-plane, using the latest beta 6 said, “oh, no ya don’t”.

That’s the bad news.

Good news is when you hold yur mouth jest rite…it’s probably the smoothest, most engaging simulation experience I’ve EVER HAD! In VR of course, with my butt-numbing gizmo. And peakin in and out of clouds with butter-smooth updates…ahhhh. I need a cigarette (if I smoked).

It’s like I don’t want to touch a single thing now for fear the 35 FPS grumpy-stutters might return.

Xp-Developer site said they are only in the first inning/phase here. Hawt dawg.

I agree…the visuals and smoothness are simply stunning…I find it hard to believe we can have these visuals and aircraft systems in our home PCs.

2 Likes

I haven’t tried the beta. But about the 3d mouse in VR: In the current and past VR editions of X-P the mouse pointer is a surprising performance killer. I keep it off permanently because I do everything with the numbchucks. If you do need it you definitely want to keep it off when not in use.

1 Like

I have been having VR controller issues in the last few 11.50 betas, mostly with X-Plane losing assignments to the axis and buttons on the hand controllers and not allowing them to be reassigned.

It started to look like this issue:

But the fix for that one, doesn’t exist anymore. That led me to this thread where others are having the same issue:

I enabled the VR Mouse Pointer (and assigned the key to disable/enable it to a readily accessible button). :slight_smile:

My performance as been sporadic. At first I was getting great performance with Vulkan enabled but then in the last beta (11.50b4) I seemed to lose it. I did notice that the fpsVR app (or was it vrFPS) was indicating that my processor was the bottleneck but I also had crashes any time I turned on any weather other than clear skies (it would complain about not having enough VRAM available (2080 Super here)) and die. I updated to 11.50b6 last night and didn’t notice any change. Going to try enabling weather again to see if that is fixed.

The X-Plane Developer blog (https://developer.x-plane.com/blog/) notes that the focus is on crashes at the moment with optimizations coming after that. There is a good chance that there is extra debug instrumentation all over the current beta builds, so that is likely slowing things down as well.

Yeah, it’s been almost a ‘cross my fingers’ thing when I run it [11.50b4+]. For my system clouds are the biggest killer. My testing scenarios are always with BKN or OVC clouds for that reason.

Right now, IMO, XP11 5.0b+ is finicky. I’m expecting that of course. I’m not sure about the startup order but how do others do that? Beech says he starts in 2D, then switches over. When do u switch, in the cockpit?

Me: Seems I get more consistent result if I have the VR headset plugged in (WMR + SteamVR) before launching XP.

Oh, I don’t use VR hand controllers; they are in a box somewhere.

I’m hopeful, but realistic (not my first flight sim rodeo), that LR w/Vulkan improves performance even more. Stable of course. I don’t own any complex add-ons, yet; my goal is to get some ‘headroom’ for these later.

I start VR, then start X-Plane in non-VR mode. Once in the cockpit, maybe after I have the GPS data loaded, I toggle VR on.

It is really weird that X-Plane went backwards with regards to controller functionality. When it first released (VR for X-Plane)…my WMR controllers worked perfectly. No having to assign buttons or anything…they just worked. Now, each time I open X-Plane they are showing something unassigned. I’m just skipping that warning and using my mouse cursor for now until they get it ironed out.

1 Like

My order of operations is:

Start Windows Mixed Reality (if it isn’t already on)
Start Steam VR (I don’t know if this step is required?)
Launch X-Plane in 2D
Set up my flight conditions and start in the cockpit in 2D.
Switch to VR.

That seems to work best for me. Only problem I sometimes get is if my computer has been on for a few hours, getting WMR to launch correctly sometimes does not happen. It boots to a grey screen and trying to close the process with Task Manager is a hit or miss process. Usually it is just faster and easier to reboot and start fresh.

1 Like

You should give them a whirl in some of the default airplanes (Laminar ones) since they are pretty well integrated. Kind of neat to reach up and flip switches. I can’t remember - did you ever try VTOL VR?

VTOL VR, no, not yet.

Think my controllers need a BlueTooth transmitter; my PC doesn’t have one and I’ve not found a Roundtuit yet :slight_smile:

I can enable vulkan in 2d restart and then go to vr. It then gives error about not being able to run in vulkan and reverts back to open gl. Bloody software

After my lil WMR debacle (fixing it) I got that. Made no sense. So I just restarted and it worked (I may have re-booted, not sure, but there were re-boots during the Fix the WMR Portal issue either way). Which made no sense either.

I had a thought recently (after a good nap), that we’ll eventually be forced to let AI write all the code. Someone way smarter than I has probably already come up with this, or is working on it.

Hey Cib. What version are you running? I ran into that with 10.50b4 when I had any weather other than the VFR default weather set.

I will check tomorrow mate thanks

1 Like

Yay! I have a work around that fixes this! Thanks to Raider030 on the X-Plane.org forums (link):

  1. Open up WMR
  2. Go to Apps > XPlane (opening up XPlane from inside of the WMR House)
  3. When XPlane is loaded up in VR go to the a) Settings Tab and then b) Joystick Tab
  4. Select Left Controller and press reset to default in the bottom left area
  5. Select Right Controller and press reset to default
  6. Press Done

In my case, the following process worked:

  1. Start WMR and get the headset all connected and working;
  2. Go to my desktop and start X-Plane (I start it in non-VR mode … by exiting while in non-VR mode);
  3. At this point the controllers will not be recognized, but set up the flight as I want and get everything setup in the cockpit (usually this means starting the aircraft and getting the GPS on so that I can enter the flight plan and set everything up as much as I can;
  4. Switch to VR mode, then go to the flight config, so that I can access the controllers setup and, if the WMR controllers for the HP Reverb were previously not working, set/reset them to defaults;
  5. Go and fly my flight;
  6. Exit VR mode and shutdown X-Plane when finished;

I don’t like this dance… but it works.

1 Like
© 2020 Mudspike.com | Articles Website | Forums Rules & FAQ