BSOD since installing new graphics card

Check which BIOS version you have

From here:

I can see the newest BIOS revision is F12Q dated 2011/03/11 which is Beta. I would try F11 first.

Also take note of your MB revision - the one you linked (and me with BIOS links) is for 1.0/1.1.

I can see that there is 1.6

and 1.7

which can have different BIOS chips

1 Like

Yeah, I will check the revision stamp on the board tonight but I think I have rev 1.7 as I checked the BIOS version last night and it was FA, but i’ll double check.

1 Like

Disclaimer: Flashing a ROM always has a certain risk to it, UEFI or not. If you have a double BIOS, it’s very unlikely that you’ll brick your Motherboard though. That said, i’ve done it several times and have never had an issue.

1 Like

Fingers crossed :blush:
Or I may be a PS4 player only for a while lol

Are BIOS versions cumulative or do I need to do each one incrementally? I’ve just read that it should be the latter… Surely the last BIOS version includes previous updates?

I have always gone the direct-to-latest route, the image should be of the entire BIOS not just a patch unless it says otherwise.

If you can find vendor specific info, that would be best.

A question: Did you fully uninstall all the Nvidia drivers before putting the Radeon card in? You could have an Nvidia component trying to run on the Radeon and crashing.

I used DDU in safe mode to uninstall the Nvidia drivers but I still have the PhysX driver entry in the uninstall panel that it keeps saying isn’t there is I select uninstall. There are no visible Nvidia folders. Not sure what’s going on there. Windows was also trying to download Nvidia drivers which I had to let it do by it didn’t seem to install anything…

There is a way to find the faulty driver(s) from a proper Blue Screen.

Read this post, starting near the bottom “The Blue Screen of Death”:

1 Like

Read it but I’m not sure what it means lol… Are you meaning I could have incorrect/damaged mobo drivers? One thing I’ve just thought of is that if I downloaded the incorrect revision version of drivers for my board? If I have rev 1.7 and I’d downloaded rev 1.0 ones instead? I know there were SATA controllers etc that I used. Could that be a problem? Would it be worthwhile (after flashing the BIOS) reinstalling Windows from scratch to make sure everything is back to square one?

If you go to the MS store and install and run “WinDbg Preview” (as administrator), you can open the crash dump in C:\Windows\MiniDump and it will analyze it and show which driver faulted and caused the BSOD. (Thats what that post outlines to do at the end.)

With that we can see if the issue is an Nvidia Driver thats left over, a bad Radeon Driver or something else.


Thanks :slight_smile: I’ll try that too.

Funny, I just had a similar situation. Got a rx580 for cheap on ebay. Plugged it into my old system, also a Gigabyte mainboard. Crashes, freezes, screen artefacts.

Turns out the card had a crypto-currency modded firmware. It was running out of spec. GPU was underclocked and RAM overclocked.
Flashed something that might be the original rom file onto the card and now it works and is clocked as advertised.
Found out by comparing clock rates displayed in GPU-Z to the specs of the chip on wikipedia. It was running 1150/2050 instead of 1340/1750. Now I hate those crypto-mining id=10ts.

Just in case you wondered what I did all Sunday long. :expressionless:


Mine was new from Amazon thankfully :blush: glad you got yours sorted though.

Then my bet is on the PSU, too. Or just a dirty PCIe slot?

Also check if there is a little switch near the back plate which allows you to switch between the main and backup bios. Some of these cards come with a „silent“ and a „performance“ bios preinstalled.

1 Like

I’d be wary of Amazon unless it was sold by, fulfilled and shipped by them. Any of the third party Vendors on Amazon could potentially bait-and-switch, which is one reason I dislike Multi-Vendor Marketplaces like Amazon (NewEgg is going this route too unfortunately).

As for the PSU, I once had an issue where my GPU required two 6 pin plugs. The PSU had to slots marked as GPU and I used two cables from those to the GPU power sockets. System failed to boot.

Moved one power cable from the PSU power slot to the PSU “PCIE” slot and everything was fine.

1 Like

Yeah it was sold, fulfilled and shipped by Amazon.

Nothing went to plan.
Downloaded the BIOS I needed and the @bios software but when I ran it it shuts down. Googled and says I need App Center from gigabyte. Cannot find anyway to download from gigabyte so found at another site. Run it and get errors about driver failure so the software won’t run FFS! Cannot get it to run so can’t update the BIOS… I don’t know what to do now.

Took out the card again, sprayed air into the PCIe port and moved it to the original port I had it in and used different PCIe power connectors. Still get the blue line 3 at boot which is I realise now the garbled Bios boot screen so does that mean that the graphics driver isn’t booting at this point?
Played a couple of games and was ok, then DCS for about an hour and was fine. It’s never crashed in DCS.

I also downloaded WinDbg preview @Wes and I only had 2 dumps from Saturday and Monday. Couldn’t get Saturdays to do anything but Mondays said it was a KERNEL_DATA_INPAGE_ERROR I think it was. This is to do with the hard drive? This isn’t making any sense now…

Those are drive errors, some don’t sound good either. There should be a further code starting with 0x…

Check all your drive cables to make sure none are loose - power and data, just to be safe.

Mace, can you download and start the tool GPU-Z and post a screenshot here?