HOTAS Warhog stick not detected

Hmmm…so I’m stuck on this one. I was getting ready to play Tiny Combat Arena this morning and my Warthog stick is not being recognized by my computer apparently. Well, it is, but it isn’t. I tried X-Plane too…and the stick is not showing up…but the throttle is. I’ve tried multiple USB ports, powered, unpowered…but something is obviously wrong.

Both are showing up in Devices & Printers:

…but the stick is NOT showing up under Game Controllers…

warthog2

Anyone run into this before? Before I start deleting drivers and stuff…was wondering if anyone had seen this and had a quick solution?

can you try the stick on another computer, that will at least norrow down if its the PC or the stick

1 Like

Happened to me after a windows update once (not recently though).
I simply re-installed the drivers over the installed drivers and it solved the problem.

2 Likes

Hmm…not having much luck. I get the boop-de-boop that the USB connection is made…and the firmware controller sees it, but after updating it goes into some time-out. The throttle updated just fine…

Yeah…no luck using the Bootloader method either. The stick simply seems to not be recognized… I wonder if I finally wore out the base/stick connection or something… I can’t complain about the amount of use I’ve gotten out of it, but I’m hoping I can find a new stick to replace it if it is indeed Tango Uniform…

I will do that too…!

I remember having this issue a while back for a long time- do all the USB ports have power saving mode turned off? It seems like some updates conveniently undo that.

Also, it may be a sign the PCB in your throttle is starting to go bad.

What are you seeing in TARGET?

3 Likes

On that ‘Game Controllers’ screenshot, I think that if you select the stick and click on properties, you should be able to move it around and see if those movements/button presses are reflected on the system. That would mean that it is ‘working’ (for some simple definition of working). I think that is going to mean the drivers are good but maybe the little computer in the stick has had it’s day and it’s gotten all cranky about doing further work.

1 Like

You should reinstall the drivers!

https://ts.thrustmaster.com/download/pub/webupdate/hotaswt/2018_TMHW_1.exe

So yeah…my old computer with the 1080…no joy on that one either. So I think it is definitely the hardware in the stick.

Yeah…I tried turning that on/off and no luck with it…

Just the throttle…no sign of the stick…

The stick doesn’t even show up in the Game Controllers menu though…just the Devices and Printers. If I click on it and try to update the drivers in the Devices and Printers it just says it is already updated. If I try using the Thrustmaster firmware update…it fails as it is waiting for the third step (communication with the stick maybe?). I tried all the above on two computers, so it is very likely the stick is bricked. Which is OK…I’ve used the heck out of it.

BUT…now I wonder if I need to buy a whole stick…or just the base? I guess that would be $169 or so versus $269…so might be worth the $100 extra to just get the whole kit. My throttle seems fine…

2 Likes

Chris, you might want to consider getting a VirPil WarBRD base…it’s a much nicer mechanism and you can use your current grip. Of course, getting a VirPil base might be a challenge right now.

6 Likes

With that, yeah, sadly the stick is dead…
IDK if were the case or not, but i strongly not recommend you all the time plug in/out all the time like many people do when not need to use vs need to use, or on the bad developed game where they detect all axis at the same time and to avoid menus scrolling and messing, the devs recommend you to unplug the joysticks every time you play that games (like many unity3d games/devs).
Usually these joysticks (cougar and warthog) are strongly sensible to electric discharges and lightning when plugin/out.

1 Like

Yep, sounds like it’s dead. I started by upgrading the the VirPil Mongoos CM2 base, which is compatible with the Warthog stick (you’ll want to use the stiffest springs to offset the weight), and the difference in feel is simply amazing. Just make sure you have a solution figured out ahead of time for mounting it, since it’s a very different solution than a stock WH base.

Best of luck!

2 Likes

$30 repair service on ebay. No personal experience with this.

Looks like we had a related topic on the Spike.

3 Likes

Curious, how old is your TM Warthog?

My TM throttle went out last summer after nearly 11 years of use. Got it October/November 2010 just after the A-10 module was released. The stick portion also developed an intermittent first stage trigger, the year before, that I could not fix. Though disappointing, 11 years is a good run after so much gameplay. I eventually switched allegiance to Virpil and have been smiles since.

To piggyback off what @chipwich was saying, you may want to give this thread a read as well. Went through it myself with Guillermot a few years ago:

When my throttle Bricked I ordered one PCB from TM through support.

I may have an extra stick PCB in my storage closet.
as I replaced my base when it fell off the stand and destroyed the plastic inner gimble, the board was fine, as I tried to super glue the inner ball and it worked until glue wore off, just replaced the entire base instead of re gluing every few weeks.

The issue is likely a ground on the PCB, as my throttle worked on some ports for a few minutes then died if I unplugged it for a while, and re plugged the same. after a few minutes the PCB would kick the unit to bootloader mode. windows sees it connected by properties will say device is not functioning properly.

I can check my closet for the old base, remove pcb, put in a static baggy with some bubble wrap and prolly mail it out next week, to NC should be chump change from here.

2 Likes

Looks like I bought mine in November of 2010…! :rofl:

3 Likes

Yeah that was a good run…
Mine is from 2010 as well and my Throttle got bricked once too so, good enough I’d say.

Chris,

You probably have noticed that I think the X56 has been sent to us by gods from the future. But more importantly, it’s cheap and easy like my sister. Get one to tide yourself over until the quality setup of your choosing finally shows up. Then sell the Logitech for a $50 loss.

2 Likes