WMR Clarity and renderTargetScale Experiments


#1

I noticed this pre-vacation and sort of forgot about it, but dug it up and there might be something in it. Here’s the trick that was going around, with some people claiming it does nothing than serve up a delicious bowl of placebo, while others claiming it changes everything and solves world hunger. The truth is probably in the middle, but it is easy to try. Steps:

Step 1. Change your WMR Steam Driver default.vrsettings file to have a renderTargetScale value of 2.0. Here’s the location of my file, and using notepad is fine:

E:\Program Files (x86)\Steam\steamapps\common\MixedRealityVRDriver\resources\settings\default.vrsettings

Here’s the line:

{
    "driver_Holographic" : {
        "renderTargetScale" : 2.0
    },
    "driver_Holographic_Experimental" : {
        // Motion reprojection doubles framerate through motion vector extrapolation 
        //     motionvector = force application to always run at half framerate with motion vector reprojection
        //     auto         = automatically use motion reprojection when the application can not maintain native framerate

So by default the ‘renderTargetScale’ is “1.0”, so make sure WMR is all shutdown (as is SteamVR) and edit the file to read ‘2.0’, save the file and on you go.

Step 2: Change your default SteamVR Video override to a fixed ‘200%’. You can use the SteamVR desktop widget menu for this, i.e. make it ‘200%’. It will look like this:

image

The important thing is not to let it vary, but fix it in the Video tab. Leave all Application values at 100% now.

So in things like DCS, just set your Pixel Density to 1.0. In things like Elite Dangerous leave the super sampling to 1.0. PCars 2 works well with these settings too. X-Plane seems to be much clearer. Essentially let WMR and SteamVR do the upscaling rather than the game I guess.

So does it work, and if so, how?

I’m not sure. It doesn’t seem to hurt at least. While intuitively it would seem that this would kill your GPU, it is likely something else is going on here, in that the ‘renderTargetScale’ value is used before the SteamVR render pipeline does it thing (before the distortion for the 3D view happens) so it’s not just a case of 2 x 200% native resolution. The SteamVR to 200% is more of a mystery, but might be to do with how the scaling math works, in that supersampling, native panel resolution and floating point numbers can get weird, so perhaps this just works for WMR and the Odyssey Plus as pure luck. Dunno.

Anyway, it is easy to try, and easy to reset back. I personally like the look of it, and everything does seem clearer.


DCS and WMR Vertical Misalignment Bug
I got the Samsung Odyssey+
#2

Can’t wait to try this tomorrow morning. Going to bed early as I go on call at 0500…ugh. They didn’t bother me today, so that was a plus. I’ve been reading the WMR threads over on Reddit and there sure is a lot of confusion on how things work with Steam VR. And it doesn’t seem constant since I also see some comments on the VTOL VR Discord about how things changed recently with VTOL and SS performance. Man, I hope this works…that’d be awesome to set it and forget it.

Also waiting to hear about any new comfort mods coming down the pipe from that VR Covers company…


#3

Also, in-case this is important, make sure the ‘Enable Advanced Supersample Filter’ is OFF. I can’t remember if it’s on by default, so this is more just to make sure (that’s the ‘Developer’ tab selected on the left):

image

This is with non-beta SteamVR app, and the Windows Mixed Reality for SteamVR [beta] app. If you change or reinstall the latter it will reset that settings file, so check for that if you do change it to beta after editing the file.


#4

Yep, it will be interesting to see what you and others think, it certainly seems subjective.


#5

I’ll be giving this a shot ASAP. Anything to stop the shimmering in my O+.

BTW, plugged in the Rift on my wife’s PC the other day. First time looking through a Rift in a few weeks. The O+ is definitely an improvement!


#6

So I tried this this morning - editing the default.vrsettings to 2.0, then setting the SteamVR manual settings to 100%, and adjusted DCS to a PD of 1.0. I find the performance to be fantastic, but I did think that shimmer was an issue. Keeping the default.vrsettings at that 2.0 level and setting DCS to PD 1.5 largely got rid of the shimmer and I still had great performance (but I haven’t tried it in a heavy object mission yet). I have yet to try X-Plane and VTOL…will report back on them.

One quick question - I did notice in that file this entry:

// Use temporal history to get higher quality motion vectors. motionReprojectionMode must be set to ‘auto’ or
// ‘motionvector’ for this setting to have an affect.
“motionReprojectionTemporalEnabled” : true,

Mine is set to true by default - which doesn’t seem to be the proper setting if you read the deprecated comments there…shouldn’t it be either ‘motionvector’ or ‘auto’ or does ‘true’ just make it so as well?


#7

OK…further testing. With renderTargetScale at 2.0 and the Steam Video Manual Override at 200%, I also get the slight shimmer in VTOL VR. If I set VTOL VR in the Steam Application to 200%, I get good performance and the shimmer is pretty much gone. By my understanding, the Application specific setting (200%) is actually a multiplier on top of the Video/Global setting of 200%, thus = 400% for VTOL VR in this case. Performance seemed fine and everything looks great.

But basically, so far I’m coming to the conclusion that renderTargetScale at 2.0 and Steam Video set to 200% gives me shimmers that I have to get rid of by bumping either the per-application setting in Steam VR up, or in game PD up.

Going to test X-Plane next.


#8

Some Reddit searching indicates this line should be true or false only…not auto…


#9

Seems like every time I launch X-Plane it has an update. :smiley: So updating first, then I’ll test it out…


#10

Wasn’t there a mention of food…I thought we were getting something to eat…:confused:


#11

The motionReprojectionTemporalEnabled has been removed from the latest WMR SteamVR beta, so I think this was just the ‘old’ ways. Try putting your WMR SteamVR library entry to the latest here:

image

When it updates you’ll need to reedit the default.vrsettings to put renderTargetScale back to ‘2.0’ I think.

One confusing thing is that WMR doesn’t use SteamVR reprojection at all. I often read that people think it does, or at least change settings for it when it’s not a part of the stack WMR would use. WMR does have its own experimental support for ASW/Reprojection, and their latest version is the ‘motionReprojectionMode’ switch in that default.vrsettings file. Because so few titles use native WMR (only from the Microsoft Store, which actually does have reprojection) it is likely you’ve never seen the Odyssey Plus reprojecting, as it’s off by default in the SteamVR bridge.

I played around with it, but it seems to really be want the running app to be at about 60 fps before it becomes useful (so it can reproject to a steady 90). Unfortunately for me, things like DCS and XP11 don’t really get to a solid 60, so WMR tends to have some pretty bad screen artfacts and juddering.

It is worth a try though. I had success with Elite Dangerous with it, which is usually a steady 70 fps for me. It is a pain that it’s in a config file, as it makes it fiddly to have to reset per VR app I want to use.

One other thing I seldom see mentioned is that WMR has the ability to lock to a 60Hz refresh rate, rather than the default 90. This can help games that can never make 90, even with reprojection. It is definitely a ‘taste’ thing to try, as some people can see the difference clearly, while others just prefer it. You can change it here, and as you can see it’s the typical Microsoft school of ‘Adventure Game’ UI design:

First, find the Settings in the Desktop WMR app:

image

Select ‘Headset Display’ on the left. Then ‘Experience Options’ ‘Change’:

Change it from Automatic to 60 (it would be using 90 usually in Auto):

image

Restart WMR and see how it feels.

PS Edited topic title just to be better.


#12

Cool. I’ll try all of that when I get home. I wouldn’t be adverse to try out the 60FPS for my non combat flight sims. The type of flying I do in X-Plane and P3D do not really require 90FPS since there just isn’t that much motion going on under most cases. A faster roll rate sim like DCS or something that might be a factor (but I honestly doubt I ever see 90 in DCS either). In 2D, I seem to be fine all the way down to 20FPS in some sims whereas some people can’t stand that.


#13

Aha…! Right you are. I was not on the WMR Steam VR beta…! That did indeed update and change my default.vrsettings file back to 1.0, so I’m changing it back and going to try again with the 2.0 and 200% in Steam VR…(see, I told you guys I can mess up boiling water!)…


#14

Sweet…! So everything @fearlessfrog described actually works great…! I was not working with the beta release of WMR for Steam, so that was why it wasn’t working to start.

DCS looks and flies great with that edit to 2.0 in the default.vrsettings file and 200% set in Steam VR Video, and 1.0 pixel density set in DCS World. I am running with MSAA set to 4x and these settings and it looks great…

VTOL VR also looks great, little to no shimmer. Haven’t tried X-Plane yet…!

So since I’m now on the WMR Steam VR beta…will that update without telling me and change that config file back to 1.0 periodically?


#15

PS - I have not yet tried the second suggestion up there about the 60Hz refresh rate. Will experiment with that later too…(I gotta go watch A Christmas Story at the moment…)


#16

It’ll be like any other Steam app, in that if there is an update it’ll be in your Steam Downloads when Steam starts up. They don’t seem to update it too often.


#17

My 2 cents or how you say ? :smiley:

I have render scale 2.0 in default vrsettings file. And shitty asw disabled, wont work good as oculus one yet.

and steam vr settings forced to manual 100%

DCS PD 1.4 and Dcs IPD (world scale) 56

Setttings in dcs:

Runs great with my oc 1070Ti :slight_smile:


#18

Still testing , Looks like no amount of PD kill enough jaggies in distance in DCS , msaa seems to must have.

:confused:


#19

Just tried it out. Way better, in my opinion. Target Scale 2.0, 200% in Steam, 1.0 PD and 2x MSAA in DCS. Still some jaggies and shimmering, but not as much as before, and the frame rate seems way higher and smoother.

Tried the 60Hz option and didn’t like it, so that’s set to 90Hz.

All around great advice, Fearless! Thank you!


#20

Btw, anyone figured out how to take screen shots in VR ? I mean something bigger than default narrow view.

Even PD wont help, it still takes orginal vr mirror view only ?

thanks.