Discourse Drops Audio Input After Working For A While

@moderator I thought about creating a new topic, but since I seem to be the only one having the problem, thought that a troubleshooting thread would die a quick death.

The problem: I can’t be heard on Discord after the first short sentence of the first transmission. For instance, I launch Discord, go to Duma, join a voice channel, and ask for a com check. I get a bunch of 5x5s in response, but then I can’t be heard after that. I can hear everyone else fine.

What I’ve tried: 1) setting discord to start with Windows 2) switched to the public test beta (PTB) 3) switched from a HOTAS button to the Z key to make sure that it isn’t a controller issue 4) switched from a USB to hard wired handset/mic. 5) Rebooted and run BIOS/firmware/drive updates. 6) Tried the suggested fixes on this page.

Team Speak and Simple Radio work fine, as well as Skype for Business. Not sure where to go with this now. Perhaps a network issue? My firewall has a public IP on the Internet facing side. I haven’t opened any ports except forwarding for DCS hosting. Weird that it works for a short while during the initial transmission then drops. Open to suggestions.

1 Like

Au contraire mon ami?

Does that solution help, as it looks @adlabs6 found a way to sort it out.

EDIT: Also, does this help? https://support.discordapp.com/hc/en-us/articles/214925018-Where-d-my-Audio-Input-go-Various-Voice-Issues-

EDIT2: Sounds (heh) similar to this one: https://www.reddit.com/r/discordapp/comments/9f6pll/help_discord_stops_transmitting_my_voice_after_15/

Trying flipping this setting or “I ended up ‘fixing’ it for now by going into the voice settings and turning off all the voice processing feaures (Echo Cancellation, Noise Suppression, Auto Gain Control). Now everyone can hear me again.”:

PS @staff is a group, plus you can use @moderators (but all the staff are moderators). If you press the ‘@’ sign first then if it’s a valid group/name then it’ll autocomplete.


Thanks almighty fearless wiki frog. I have tried all of those except the last one “Enable Quality of Service…” Will try that next.

1 Like

I added the edit, if worth trying these.

It sounds like your connection is being dropped or filtered out, so it assumes you’re gone and auto-mutes as a bug. They have a big ol UDP range they use, although I’d need to go look up the exact numbers if this doesn’t work.


I have never had a problem although I must admit that I haven’t used Discord Voice all that much. I have all the doohickies (official southern term, look it up) turned on except Attenuation “When I speak”. Also, I use ptt, not voice activation.

1 Like

I tried disabling all of the doohickies first, but in the end the solution turned out to be disabling Enable Quality of Service High Packet Priority in Settings → Voice and Video. Thanks so much guys!

1 Like