MSFS VR - Everything you NEED to know! | HP REVERB G2 & RIFT S

4 Likes

I have no big hopes for my rig, but I’ll try it very soon!

Oh geez. Oh god. My poor head. And rig. Ah geez. Nope.

Just spent an hour or so trying to get MSFS, my 1070 and the G2 to play nice. Ain’t happening.

1 Like

Put the Global Rendering Quality to the ‘Medium’ preset and then pull down the ‘Render Scaling’ to about 50% and Anti-Aliasing to OFF. That will render less pixels than a typical 2K screen, and will look bad, but might run on a 1070.

2 Likes

Got it running somewhat flyable here, on an i7 7700k @4.8ghz and a RTX2080
Using 100% render scale in-sim, and 50% in SteamVR, with TAA on.
Results in some pretty bad, all in the red, frame times on both GPU and CPU in fpsVR though, but it seems reasonably smooth despite that.

Btw, is there a way to remove the prop blur, i find it’s extremely anoying in VR ?

If using the SteamVR OpenXR stack, then you can disable motion smoothing for prop blur.

2 Likes

How does one control motion smoothing with the Microsoft OpenXR stack thing?

I did a short flight. Pretty low settings but it kinda works.
I only have a weird black frame on my screen, not sure what it is.

The WMR OpenXR motion smoothing is in preview (it’s just come out) so you can turn it on/off using the ‘OpenXR Developer Tools’ util. It should be here via the Store:

https://www.microsoft.com/en-us/p/openxr-developer-tools-for-windows-mixed-reality/9n5cvvl23qbt

2 Likes

TYVM sir :salute:

1 Like

Any idea what could cause this?

Those black frames move with my view, and they are in both eyes.

It’s the Oculus stencil mask, update your Oculus software as it’s been fixed in their latest release. If you don’t want to do that then the workaround is:

Go to the Oculus Debug tool:
Default folder should be C:\Program Files\Oculus\Support\oculus-diagnostics
Open the Oculus Debug Tool
Turn the option “Use FOV Stencil” to Off

3 Likes

Thanks, I’ll try that!

1 Like

Oculus Rift i7=4770k- gtx1080…

Lot of jittering with head movement. I noticed when I focus my mouse outsite the MSFS window (on second monitor) head movement is smooth… I see a same kind of mouse related performance drop with X-plane, here I disabled the mouse when don’t need it… don’t see any options to disable mouse here. Not flyable this way…
Update: updating my Nvidea drivers to 452.06 seem to solve my problem. Perfomance comparable with X-Plane with ortho. Not the best but flyable. With a lot on low settings.

1 Like

I’ve not seen that issue before @Ghost_Unit13 so not sure what to recommend there - sorry.

All - here’s where they are keeping the Known Issues list:

2 Likes

Hey thanks, that worked, prop is now fine, and on top of that CPU frametime is better than ever. Seems like the CPU is doing very little work, without motion smoothing on.
The GPU on the other hand, is working overtime, but it can aaalmost hold it at 40 FPS, but not quite. (Index running at 80 Hz)
Its showing some nasty frametime spikes, and is pretty much maxed out it seems.
Is there and overview out, of the different settings, and what they affect the most, yet?

^ First post has some stuff (in the 'Tube)

1 Like

Yep, I watched that, I was hoping for something a bit more in depth, but its a good start for sure.

I find Youtube an insufferable medium for the transfer of information such as “click this setting to get that effect”. Why can’t the fokker just write a post, ffs.

@fearlessfrog, that dev thing to turn on motion smoothing did a whole heapin’ lot of good! I might actually fly a bit now! Thanks!

1 Like

It’s still all a bit Wild West times, as the update today changed a lot of things that would have been good advice from the VR beta. At a top level though, there are two main ends of the rope to play with in terms of performance:

(a) the Sim end settings and its output resolution (game).

(b) the headset custom resolution and motion reprojection (post).

For (a) and the sim settings, the following make the most impact (I haven’t really verified this today, but it should be similar, if I’m completely wrong I’ll edit this message and blame DIscobot later).

  1. Render Scaling. You can play with this in combination with the Anti-Aliasing settings, especially TAA, which works really nicely in VR for giving details and smoothing. Example:

60% Render Scale + TAA - works pretty nicely in the C152, as the dials look good and the outside nice and smooth.

100% Render Scale + No antialiasing - works nicely in the A320 if you stare at the MCDU all the time and not outside.

Combo of (a) and (b) 75% + TAA and then a Custom Resolution of 150% on the Reverb G1.

So effectively play with different combos where you set a low game resolution plus use TAA and then oversample on the headset side (either in SteamVR or in the OpenXR util with ‘Custom Resolution’).

  1. Terrain LOD - try 50%, it really helps the vertices and doesn’t look much different.

  2. Volumetric Clouds. Above Medium hurts VR a lot.

  3. Glass Cockpit Refresh rate. High, as otherwise you get judders when it misses a frame on things with lots of glass./

  4. VR Traffic. Just try turning them all off, and then perhaps Road Vehicles back to 20. Very CPU intensive, so try to pair down unless running a monster.

There’s some historical info from the beta here, that’s now vieawable. It covers a lot of the witchcraft of Nvidia control panel settings, HAGS on/off, eye of newt etc. I can’t say if any of it is correct, but it’s interesting to look through anyway.

EDIT: Rather than be about a video I didn’t watch, I just created a new topic here for my settings:

4 Likes
© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ